TPG Community

Get online support

USB Sharing with TP-Link VR1600v - write access not working

Level 3

The modem supplied by TPG according to the manuall Pages 32-41 can have a storage disk on the USB port.

By default it is read only but has the ability to have write access enabled.


I have done this as you can see in the picture, exactly as shown in the manual page 37 (PDF page 40)

USB Storage device.JPG

However all that happens on my Windows 10 computer is that the files are read only.

In Windows file manager the drive is seen as Archer_VR1600v, but with naming it "Folder Name" see picture above, I would wxpect to see a folder called F-Drive. This is not the case.

Following the advice on this link does not solve the problem.

Thank you for any help provided.



Hi @SineNomine, may we know what file system your hard drive is formatted?


Please be advised that NTFS is not supported for write access, but you can try FAT32 and check if write works.

Level 3

Hello Riezl

Thank you for your reply.

I had tried with an NTFS, and as soon as it was incerted it wrote some operating directories. Furthermore it scanned the whole drive. I was able to read from it but not write. When I returned the drive to a standard USB port, it had changed all files to read only, because according to the computer I no longer had ownership. It took ages to regain ownership of everything on the drive.


I have since tried with a FAT32 drive, this time an empty drive, and created a folder to drop files. Again it automatically created folderd (All the ones in the picture below, except Data, which I created as a location to drop files). However, I can still read but cannot write. The modem asks me to create a 'folder name' but I can never see it in file explorer. The only thing that File Explorer is the orginal as seen here.

USB Storage device 01.JPG

Right clicking these folders for properties or to change attributes does not exist.

I have tried every combination that I can think of, including the setting in the manual similar to this.

USB Storage device 02.JPG

The above is from my eqipment not the manual. I have tried with and without 'Enable Authentication' as well as 'share all' switched on or off. Having created a folder name 'ModemData' I expected it to be somwhere in file explorer, but it is not. Just 'Archer_VR1600v'


If 'Enable Write Access' is ticked, Is there anything that I have missed?




Hi SineNomine,


These type of specific detailed issues regarding usb file sharing is beyond our scope of support. Apologies if we're unable to assist you any longer as we do not want to cause any further issue on the modem. 


You may try to contact TP-Link directly using one of the avenues below for further assistance:


Thank you! 

Level 8

Hi @SineNomine I've done some testing using the default USB sharing settings on a VR1600v, I used a 4GB flash drive which I formatted in NTFS on a Windows 7 Pro machine, I wrote a couple of files to it while it was still in the PC, I then mounted the volume once plugged into the VR1600v using the interface prompt.


I had to enter the same username and password I use to access the VR1600v to access the drive (once only). I was able to read and write to the flash drive without a problem.


I then unmounted the USB volume using the VR1600v interface before unplugging it from the router and back into the PC, once again I could read and write to the drive without issue.

I believe the issue you're having is a privilege and permissions issue more to do with Windows 10 rather than the VR1600v.

VR1600v USB NTFS write test WIN 7.jpgVR1600v USB NTFS write test WIN 7 2.jpg



Level 3

Hello Orbistat,

Thank you for going to so much trouble. It is most appreciated. It's good to know that it does work.


Since I am the only user on my computer I thought that I am logged on as administrator (well I know I am). I have achieved some of what you have done. IE send files to the local USB drive then plugged it into the VR1600v, - I can read but not write. Agreed you have to log in for the first time.


Right-clicking any file name for properties, properties is not even listed or greyed out. So somehow I have to figure out what settings in windows 10 will sort.


The first time I did it with an external hard drive, - the second a USB stick, the latter did not have the same problems when returning it to a standard USB port - in other words, I did own the stick and the files, so I could read/write delete etc.


It is good to know that it can be written to, I just need to work out the puzzle.


Thank you

Level 2

I am also having problems 'seeing' my USB drive.  How ridiculously difficult this is.  


Orbistat helpfully wrote " . . .I then mounted the volume once plugged into the VR1600v using the interface prompt." 


How mounted? What 'interface prompt'? And is this in File Explorer? Can anyone provide a bit more detail please? Windows 8.1 x64.


Th closest I can come to seeing anything with regards to the USB stick is the attached. 

Level 8

Hi @Erbmit have you logged into the VR1600v and navigated to USB sharing? Once you have, click on the (?) icon and all the information you need will be there.


USB sharing.jpg