TPG Community

Get online support

'Weak security' for Archer VR1600v modem router

Pattie
Level 2

Hi,

I'm getting a "Weak Security' message on my wifi network. Using an Archer VR1600v modem router. I have searched for similar questions in the community, but all are for different modem. It seems I need to update the settings to WPA2/WPA3 Personal (AES) Can I adjust the settings online?

8 REPLIES 8
david64
Level 12

Hi @Pattie . Login to router. Go to Advanced, Wireless, Wireless Settings. You can select WPA2 and AES. The VR1600 doesn't do WPA3.

Pattie
Level 2

Thanks @david64. I followed your instructions, as below:

 

Screen Shot 2021-09-18 at 10.17.47 am.pngBut unfortunately still have the 'Weak security' error. I also restarted my computer and restarted the modem to see if the new settings would implement and update the 'weak security' but to no avail.

Are there any other options? Do TPG have a modem/router with WPA2/WPA3 security?

david64
Level 12

@Pattie . Which device is giving the weak security message? Are you still able to use it?

In the screen shot, you are displaying the 5G network but it is not enabled. Does the 2.4G network have the same security settings?

The TPG routers only have the WPA2 level.

 

Pattie
Level 2

@david64 All devices connected to wifi are giving the weak security message. They are all apple devices, Imac, iPhone iPad etc, but they can still be used and the wifi still works. I was just concerned about the weak security.

Here are the settings for the 5G network and the 2.4G network is below.

Screen Shot 2021-09-18 at 1.37.30 pm.pngScreen Shot 2021-09-18 at 1.37.46 pm.png

Okay, so could there be a problem with the apple OS? or are there other options such as 3rd party routers/ modems? What could be the way to fix this? I'd prefer not to continue indefinitely with weak security.

david64
Level 12

@Pattie . Have you recently upgraded to IOS14?

The VR1600 only has WPA/WPA2 combined but it should prefer WPA2 over WPA. WPA2/AES is the proper setting. There are probably routers with WPA3; you would have to check. The TPG VOIP phone service only works on their supplied router.

 

Following is from Apple blog re this message and IOS14:

Sep 18, 2020 7:09 AM in response to BSM767

Had to do a little experimenting. My iPad and iPhone also had the same complaint. Yup, my router was set to WPA/WPA2. I had it that way because my wife's old iPhone (which we no longer have) wouldn't connect to WPA2.

 

I changed the router's setting to WPA2 only (no option for WPA3). Went back to the iPhone and it was still complaining about WPA. Turned the phone's Wi-Fi off, then back on so it would reconnect to the current setting. Still complained about WPA even though it was no longer being used by the router. Finally, I shut the phone down completely, waited a few moments and powered it back up. The security message was finally gone.

Pattie
Level 2

Hi @david64,

I have finally found the problem. The weak security is actually because of the Dlink range extender being used in the house. I have since removed the extender and moved the modem to a more central location in the house and the weak security has disappeared. Thanls heaps for your help it's greatly appreciated.

However in doing this, I now have a new problem. After moving the modem, i reconnected the phone to the phone 1 port and it's not working - nothing is lighting up in the phone 1 area on the modem. all other relevant lights are working. The internet is connected. The phone has a dial tone, but when it connects it's just a long Beep. Do you have any knowledge as to what might be happening?

Pattie
Level 2

Hi again, @david64 ,

Problem solved, I was just a bit too impatient in waiting for the modem to connect the phone line. I followed the setup instructions and everything is back to normal with no 'weak security'. Thanks heaps for all of your help.

david64
Level 12

Hi @Pattie . Out of interest, what is the model of the D-Link extender? One model I looked at has settings to disable security on the extended wifi. Might have been the case with yours.