weak securtiy

spiderman
Level 2

I have just purchased a DLink DAP-1650 wi-fi extender and i keep getting the weak security notice...i cant even get the Dlink to connect to the router which is an Archer 1600v. I have changed the settings on my modem per the Dlink website but no change .....I do not require a home phone do i need a WPA 3 Modem.

2 REPLIES 2
david64
Level 13

Hi @spiderman .

Does your wifi device get the weak security message when it connects to the Archer wifi?

 

Manual is here: http://files.dlink.com.au/products/DAP-1650/Manuals/DAP-1650_A1_Manual_v1.01(DI).pdf

 

Are you using D-Link in Repeater Mode? It picks up Archer wifi signal and extends it. D-Link must be close enough to Archer to get a good signal. Repeater mode has to be set in Wireless Mode Settings.

 

On the D-Link, you can set the security as follows:

Select WPA-Personal from the drop-down menu.
There are two versions of WPA supported by the DAP-1650: WPA and WPA2. It is recommended that you use Auto(WPA or WPA2) so that the WPA2 version will be used if connecting wireless clients support it.
Choose a cipher type from the drop-down menu.   AES is best.
Enter the desired pre-shared key (password) for the wireless network. Wireless clients will need this key in order to connect to your wireless network.
Click Save Settings at the bottom of the page to save the current configuration.

spiderman
Level 2

Thanks David

 

Yes i want to use it in repeater mode to extend my wifi signal. Yes its a weak signal only for the router.

 

I will try what you have recommended tonight. The salesman said yes its easy just plug it in and connect to your modem...not likely.

 

Thank you