TPG Community

Ask, answer and talk about our products

Connecting ASUS RT-AC68U to NBN

SOLVED Go to solution
Level 1a

Want to share this as it took me some time to work out how to connect my ASUS RT-AC68U to the TPG NBN. There seems to be plenty of help on the dsl version of this router but not for the above.

You basically need to set the VLAN setting to 2 but this setting on the modem is in the most hidden location that one would not be able to find.


Under Advanced Settings > click on LAN > click on IPTV tab > under LAN Port select Manual Settings from the list of ISP's > set Internet VID to 2 and PRIO to 0.


Assuming you have already setup your username and password and other obvious setting when the above is appied it worked.


Hope you find this usefu!!!


Hi @anthonylamb


Thank you for sharing that information and the screenshot.


This will be very useful for customers wishing to set up that particular router on TPG NBN.


A related Community post regarding the same ASUS router and NBN HFC can be seen here:

Replace Huawei router with ASUS ac87u Plug straight into NTD of HFC NBN

* * * *
Have you seen a helpful comment lately? Be sure to give it a Like.
If a reply to your question solves the problem, be sure to mark it as an Accepted Solution.
* * * *
Level 1b

Thanks @anthonylamb that did the trick.

I have an ASUS RT-AC86U, and couldn't connect.


Setting the following:

1) Setup WAN

WAN (Menu) -> Internet connection (tab)

  • Protocol: PPPoE
  • MTU and MRU: 1492
  • login: TPG username
  • password: TPG password

2) Set VLAN ID to 2

LAN (Menu) -> IPTV (tab):

  • Select ISP Profile
    • Manual Setting
  • Internet
    • VID: 2
    • PRIO: 0


Level 2

thanks @anthonylamb that worked!

Level 1c

Hi, is there any user with DSL-AU64U have issue with TPG vlan ID 2. 

I called ASUS and they keep saying this modem should working and the issue is with TPG but this is not TPG issue. I am going to log complent with Australian Consumer law so looking for more users to join as this is Asus issue and they not accepting this or offer any fixes. 

reply to this or message me if there Option for PM so more users complain join then it will be a strong case.

I have some evidence but looking for more users 

Level 1b
Thank you. Worked first attempt. Only needed to change ISP to TOG for the connection to be made.