TPG Community

Ask, answer and talk about our products

Cannot send/receive SMS on TPG Mobile - Unable to update SMSC number on Android Pie

SOLVED Go to solution
Level 3

Hi, I've searched the boards and have been unable to find a solution to sending SMS with the TPG Sim card on a recent purchase of a Nokia 7 Plus running Android Pie. I have used the following steps to get to section to update the SMSC number, which is successful, however I am unable to update.

 

  1. From your Home screen, tap the Application screen icon.
  2. Find and tap Phone.
  3. Type *#*#4636#*#*.
  4. Tap Phone information.
  5. Scroll down to SMSC.
  6. Enter the relevant SMSC number in the input field, then tap Update.

First I should mention, once I'm in Phone info, the first section not selected is "Set preferred network type". It is set to 'unknown'. Pls. advise the correct setting, for example, is it TD-SCDMA only, is it LTE/TD-SCDMA? Those are only two options of very many options to select and I have no idea which to select (there is no 'auto' option).

 

Further down the Phone info section, I come the SMSC section which is not filled in. So I type in +61415011501 and click Update. The value I typed in is replaced with 'update error'. Clicking Refresh fills the SMSC field with "+61415011501",145.

 

This does not solve the problem and I am still unable to send SMS.

 

Further down Phone info, Mobile info refresh rate is disabled.

 

This is extremely frustrating and a disaster as anyone sending me a SMS do not get any indication that their message was not succesfully sent/recieved.

 

Please help!!!!!!!!!

5 REPLIES
Moderator

 Hi gmakosyd,

 

We're sorry to learn that you're having issues with the service. Here are some steps you can also try: 

 

1. Turn off/on your mobile phone to refresh.
2. Check your SMS center number, it should be +61415011501

  • Press the Home button
  •  Tap on the Phone icon
  • To view the SMSC number enter *#5005*7672# and tap Send
  • If SMSC number is incorrect enter **5005*7672*+61415011501# and tap Send


3. Try different mobile phone to check if service will work.

If all else fails, kindly provide us with the error message that you are getting. We can also organise a contact to be made from our Mobile Technical team for assistance. Just let us know of your best contact number and your most convenient time to receive a call via private message

 

 

Thank you. 

Level 3

Hi Ahra-G,

 

Unfortunately not successful with your suggestions. I have sent you a private message.

 

Regards, gmakosyd

Moderator

Hi @gmakosyd,

 

Thanks for sending us the details of the troubleshooting result. We'll arrange one of our Mobile Technicians to call you for further test and investigation, tomorrow between 9-12NN Sydney time.

 

In case you have a different preferred contact time feel free to let us know.

 

Cheers!

Level 3

Hi Shane,

The problem has been solved. In one minute I did something that I should of done two days ago to solve this... I long-pressed the SMS msg that would not send and clicked on the View Details option. As it turned I was trying to send a SMS to his home phone number..... D'oh! It should not of happened though as I was able to SMS my friend fortnight ago so never occurred to me it was the destination number and not anything more complicated!

 

My friends mobile number is set as the Default number in his Google Contacts profile (mobile labelled as Mobile and landline labelled as Home) so that should of been the default number used in the To: field in both Messages and Textra SMS plus also when I swipe left to call and right to SMS. Yet Google Contacts served up the landline number to these external apps this time around. Thought it might of been a duplicate contact record but that wasn't the case. Not sure how this substitution happened but now I know this is one thing for me to check in future SMS send fails (and for you guys to add as a check if other customers have a similar issues like mine): make sure it was sent to the correct number if the person has several numbers in their Contact record... just in case it was a Google gremlin.

Highlighted
Level 3

When I say the mobile number was set as default I didn't mean that because it had labelled the mobile number as Mobile and landline as Home. What that meant was when clicking on the three dots at the top when viewing a google Contact brings up several options, with the first being "Set Defaults". Both his mobile and landline appear with the radio button for his mobile number selected as Default.