TPG Community

Ask, answer and talk about our products

No button to activate sim

Level 1c
TPG has stuffed up at literally every step of my registration process at this point, first they messed up my original registration so called me and I did it again over the phone, then the rep put me down for the wrong plan (despite mentioning the correct plan over the phone) now a few weeks after I originally tried to register I finally have my son yet there is no activate sim button on my account... (Just says commencing installation). Can someone fix this please....
11 REPLIES 11
Moderator

Hi @Drakonn

 

Welcome to TPG Community! 

 

We're sorry to hear that you're having issues in activating your SIM. I have checked your account and it seemed that there should not be any hindrance in activating your SIM. 

 

Here's a link to guide you with the activation: How to activate your TPG Mobile SIM card

 

Please ensure to use your TPG Customer ID when logging in to 'My Account' and select the correct Plan ID. I'll send the Plan ID via private message. 

 

Should it still not work after following the steps on above link, kindly provide us with your best contact time & number via private message so we can organise a call back to be made from our Mobile Team for further assistance. 

 

 

Thanks! 

 

Level 1c
Okay so now the activate sim button has finally appeared (wasn't there when I posted this...) I clicked it got an email saying my number port was successful yet my new SIM doesnt work... How do you stuff this up so much surely it isn't that friken hard. My old sim is also inactive now so I can't use my phone because of your ** up. Thanks for nothing. Yes I've tried all the normal stuff like restarting my device etc. I have signal on the TPG sim yet I can't actually friken call anyone I need to be able to use my phone to contact people and I can't now so thank you for screwing up once again.

I get the "welcome to mobile support please activate your sim blah blah blah" when I call anyone with the new TPG sim in my phone.
Moderator

Hi @Drakonn

 

I've checked on your Mobile Sim account and can see that this has now been completely activated recently. 

 

If the issue persists, please restart your mobile device. 

 

Let us know how it goes. 

 

Level 1c
I've already restated three times still nothing what the hell is going on here?
Level 1c
I made a ticket with tech support with more details if you need them everything I could think of is there.
Moderator

Hi @Drakonn

 

Regrettably, I am unable to find the report that you've mentioned. 

 

Did you call us using a different number? If you can provide us a reference number for this, we would appreciate this so that we can chase this for you. 

 

On the other hand, can you please also DM us the SIM card number which is located on the back of your SIM. 

 

Regards, 

Moderator

Hi @Drakonn,

 

Our Mobile specialists has made changes and has confirmed to us that this issue should now be fixed. 

 

Should you need further assistance, please let us know. 

 

Regards, 
 

Level 1c
Hi Erika, it is better but not fixed. I can now call and use data yet I can't send texts? (Says failed to send) I can receive texts fine just not send them?
Moderator

Hi @Drakonn,

 

Thanks for confirming and apologies if there's still some issues with sending SMS. 

 

I've made some changes on your account and it should help sort this issue. 

 

Please restart your mobile and try to send a test message to your own mobile number.

 

Let me know how it goes. 

 

Regards,