TPG Community

Get online support

Sim activation issues

Highlighted
Level 2

Hi I’m new to TPG only having got my new sim for month to month on Friday

 

I activated the sim on Saturday online. I knew that nothing would be done on Saturday or Sunday but expected that my service would be activated & number ported by today Wed as it states on the website that mobile porting takes between 24 - 48 Hrs.

 

So when i rang today to check why my service isn't active i was bit amused to say the least to be told there was an problem & it would be 2 - 3 more days before it would be active .  When i asked what the issue was i was told it was an issue with porting the number. I said it might have been nice if someone had emailed me this update.

 

So I rang my other mobile provider and asked why there was an issue with my number being ported. They informed me they hadn't received any porting request from TPG as yet as soon as they did it may  takes them up 24 hrs to port but that should be maximum it does .

 

So I contacted TPG support again to ask again what the issue was & was told again it was a porting issue. When I told the agent I had contacted my other mobile provider & they said they hadn't received any porting request, I was put on hold, when they came back the story had changed now I was told there was an issue with activating the sim on TPG side. That they had emailed the techs & they would be back to then in 2 to 3 days.

 

I explained that I couldn't wait another 2 - 3 days as this would then mean my other mobile service would already be deactivated & I would be without a mobile service. I was informed nothing they could do as they are unable to contact tech direct.

 

When i said i would be quicker cancelling this service and buy another i was told that wouldn't work as the service was being processed for my mobile number which doesn't allow any other service to activate.

 

So now I’m stuck my existing service is ending tomorrow & the TPG one they can't tell me when that will be active at all. 

 

Not a good start with TPG at all  

3 REPLIES 3
Highlighted
Moderator

Hi @ozeire

 

Welcome to the Community! 

 

We're sorry to learn about your recent experience as this wasn't the type we aim to provide specially for a newly signed up customer.

 

I've managed to locate your account using your Community details and based on your recent interaction with our support, the case is now raised to our Network Engineers for further investigation and to fast track a resolution. 

 

We'll be sure to contact you as soon as an update becomes available. 

 

 

Regards,

Ahra_G

 

Highlighted
Moderator

Hi @ozeire

 

We've already detected usages on your mobile service which should mean that it is already working. 

 

Should you require further assistance, you may reach out to us again or you may check out our self-help options located here: http://tpg.com.au/support

 

 

Thanks! 

 

Highlighted
Level 2

Yes my service is working now but took multiple calls over several days and esculating to manager or 2 to get working . Shouldn't be that hard to activate a mobile & port a number.

 

If your agents would update us on what's happening would leave us customers in a happier place .

 

It all comes down to customer service .