TPG Community

Get online support

Cannot use port forwarding on TPG modem VX220-G2v

SOLVED Go to solution
Level 3

I don't find any setting for CWMP in the router. 

From the internet, if I can connect port 7547 successfully. Do "telnel public_ip 7547" works! Seems the CWMP is maybe enabled by firmware by default, and we can't seem to change?

My VX220 is using:
Firmware Version: 2.0.0 0.9 v603c.0 Build 220517 Rel.49186n
Hardware Version: VX220-G2v v2.0 00000000

Level 15

@binhdo26 . Did the telnet to 7547 return a text string?


Do you know anyone who could set up a reverse test? They would create a rule for port 8080 to port 80 to any active ip address on their local lan. Use your browser with their wan ip address. There should be an immediate reply like connection refused. There won't actually be a web server running on their computer.


TPG always say in these cases that they don't block any ports.

Send a private message to a moderator with a link to this thread. Ask if the VX220 is blocking inbound connections.

- the addressing from internet is correct

- the server setup is correct, it is accessible locally

- the forwarding rule is correct.


Level 15

@binhdo26 . Only other thing I can suggest is to remove the Service Type PTL from the rule.


This user is doing port forwarding on same model and firmware as you.

His problem was some extra equipment that wasn't working as expected. When that was fixed, forwarding worked.


Level 3

When telnet to public_ip port 7547, it wouldn't return anything, just showing a blank until I hit ctrl+C to exit, it would return like the attached photo. 


Thanks @david64 , I don't know any who could set up a reverse test, I'll send  a private message to a moderator and see, also call to the support hotline

Level 3

Thanks @david64 @BasilDV for your help. I wouldn't have to factory reset as @BasilDV has recommended. 

Turns out that all I need is just to reboot the wifi modem. As the wifi modem get hung somehow. Seems strange because we just switched from my previous to TPG recently for about nearly a week. 

Port Forwarding is working now at my side and I can open ports as I want.