TPG Community

Ask, answer and talk about our products

Github not accessible

Level 2

I cannot ssh to github.com at all not on port 22 not on port 443

mo@Mos-Mac:~$ traceroute github.com
traceroute to github.com (140.82.118.3), 64 hops max, 52 byte packets
1 192.168.1.1 (192.168.1.1) 3.172 ms 0.912 ms 0.746 ms
2 10.20.22.137 (10.20.22.137) 9.077 ms 10.779 ms 10.586 ms
3 203-219-155-2.tpgi.com.au (203.219.155.2) 12.518 ms 12.832 ms 12.280 ms
4 syd-apt-ros-crt2-be-10.tpgi.com.au (202.7.171.153) 20.384 ms 19.174 ms 23.563 ms
5 syd-apt-ros-int1-eth8-3.tpgi.com.au (203.29.134.67) 20.506 ms 27.451 ms 24.070 ms
6 100ge13-1.core1.sjc1.he.net (216.218.139.233) 349.528 ms 197.194 ms 235.789 ms
7 100ge1-1.core1.sjc2.he.net (184.105.65.114) 378.688 ms
10ge7-2.core1.sjc2.he.net (72.52.92.118) 194.619 ms
100ge1-1.core1.sjc2.he.net (184.105.65.114) 278.619 ms
8 100ge10-2.core1.nyc4.he.net (184.105.81.217) 239.811 ms 353.459 ms 307.462 ms
9 100ge16-2.core1.lon2.he.net (72.52.92.165) 614.630 ms 452.768 ms
100ge11-1.core1.nyc5.he.net (184.105.213.218) 311.702 ms
10 100ge8-2.core1.dub1.he.net (184.105.65.246) 515.424 ms
100ge6-2.core1.ams1.he.net (72.52.92.214) 355.063 ms 306.632 ms
11 100ge3-2.core1.man1.he.net (72.52.92.197) 295.336 ms 378.730 ms
80.249.213.114 (80.249.213.114) 368.810 ms
12 * 100ge16-1.core1.ams1.he.net (184.105.213.65) 415.966 ms 304.851 ms
13 * * 185.1.94.37 (185.1.94.37) 422.440 ms
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * *^@ *
20 * * *
21 * * *
22 * * *
23 * *^@ *
24 * * *
25 * * *
26 * * *
27 * *^@ *
28 * * *
29 * * *
30 * * *
31 * *^@ *
32 * * *
33 * * *

 

i can telnet on those two ports though

 

mo@Mos-Mac:~$ telnet github.com 443
Trying 140.82.118.4...
Connected to github.com.
Escape character is '^]'.
^]
telnet> quit
Connection closed.

 

mo@Mos-Mac:~$ telnet github.com 22
Trying 140.82.118.4...
Connected to github.com.
Escape character is '^]'.
SSH-2.0-babeld-80573d3e
^]
telnet> quit
Connection closed.

 

when i do ssh it times out

 

mo@Mos-Mac:~$ ssh -vvT git@github.com
OpenSSH_8.0p1, OpenSSL 1.0.2r  26 Feb 2019
debug1: Reading configuration data /Users/mo/.ssh/config
debug1: Reading configuration data /usr/local/etc/ssh/ssh_config
debug2: resolving "github.com" port 22
debug2: ssh_connect_direct
debug1: Connecting to github.com [140.82.118.3] port 22.
debug1: Connection established.
debug1: identity file /Users/mo/.ssh/id_rsa type 0
debug1: identity file /Users/mo/.ssh/id_rsa-cert type -1
debug1: identity file /Users/mo/.ssh/id_dsa type -1
debug1: identity file /Users/mo/.ssh/id_dsa-cert type -1
debug1: identity file /Users/mo/.ssh/id_ecdsa type -1
debug1: identity file /Users/mo/.ssh/id_ecdsa-cert type -1
debug1: identity file /Users/mo/.ssh/id_ed25519 type -1
debug1: identity file /Users/mo/.ssh/id_ed25519-cert type -1
debug1: identity file /Users/mo/.ssh/id_xmss type -1
debug1: identity file /Users/mo/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.0
debug1: Remote protocol version 2.0, remote software version babeld-80573d3e
debug1: no match: babeld-80573d3e
debug2: fd 5 setting O_NONBLOCK
debug1: Authenticating to github.com:22 as 'git'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256
debug2: host key algorithms: ssh-dss,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr,aes256-cbc,aes192-cbc,aes128-cbc
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr,aes256-cbc,aes192-cbc,aes128-cbc
debug2: MACs ctos: hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib,zlib@openssh.com
debug2: compression stoc: none,zlib,zlib@openssh.com
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: rsa-sha2-512
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ssh-rsa SHA256:nThbg6kXUpJWGl7E1IGOCspRomTxdCARLviKw6E5SY8
debug1: Host 'github.com' is known and matches the RSA host key.
debug1: Found key in /Users/mo/.ssh/known_hosts:1
debug2: set_newkeys: mode 1
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /Users/mo/.ssh/id_rsa RSA SHA256:yeZcjRYGdYTBlaKZ/HKXjKDyGQjUdn1oEwP1o4o4r5Q
debug1: Will attempt key: /Users/mo/.ssh/id_dsa
debug1: Will attempt key: /Users/mo/.ssh/id_ecdsa
debug1: Will attempt key: /Users/mo/.ssh/id_ed25519
debug1: Will attempt key: /Users/mo/.ssh/id_xmss
debug2: pubkey_prepare: done
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa,rsa-sha2-512,rsa-sha2-256,ssh-dss>
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/mo/.ssh/id_rsa RSA SHA256:yeZcjRYGdYTBlaKZ/HKXjKDyGQjUdn1oEwP1o4o4r5Q
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: /Users/mo/.ssh/id_rsa RSA SHA256:yeZcjRYGdYTBlaKZ/HKXjKDyGQjUdn1oEwP1o4o4r5Q
debug1: Authentication succeeded (publickey).
Authenticated to github.com ([140.82.118.3]:22).
debug1: channel 0: new [client-session]
debug2: channel 0: send open
debug1: Entering interactive session.
debug1: pledge: network
debug2: channel_input_open_confirmation: channel 0: callback start
debug2: fd 5 setting TCP_NODELAY
debug2: client_session2_setup: id 0
debug2: channel 0: request shell confirm 1
debug2: channel_input_open_confirmation: channel 0: callback done
debug2: channel 0: open confirm rwindow 32000 rmax 35000
client_loop: send disconnect: Broken pipe

 

7 REPLIES 7
Moderator

Hi @melsayed34,

 

Welcome to TPG Community!

 

We've checked the test that you've provided and it requires further investigation.

 

We've escalated this case with our Engineering team and they'll be in touch with your within 24 to 48 hours via SMS or phone call on the number that we have on file.

 

Should you require further assistance, please let us know.

 

Kind regards,

BasilDV

Level 2

Thanks @BasilDV it was really frustrating trying to call up customer support about this, appreciate the help.

Level 2

I'm still experiencing the same problem, tried different computers. the problem is with the TPG network. I'm opening an official complaint with TIO

mo@Mohameds-MBP:~$ ssh -T git@github.com
packet_write_wait: Connection to 13.236.229.21 port 22: Broken pipe

.

 

 

Moderator

Hi @melsayed34,

 

We've seen that this has been previously escalated to our Engineering Team and you have been in contact with one of our Engineers found no fault on our our network. The service has been connected for 3weeks 1d 9m.

 

We are providing/responsible for the path and destination but not the access of any specific website since this is a NBN Residential comes with Dynamic IP address. We've seen that our Engineers recommended to refresh or turn on/off the modem/router.

 

Let us know how it will go.

 

Regards,

Level 2
Hi Shane,
Do you really think I would go to this length and open a case with TIO for an issue that could be solved by restarting my equipment ?!
I can forgive most things but not insulting my intelligence really. Anyways the issue is yours and I’m gonna go all the way to prove it. I’m only willing to let it slide if you terminate my contract so that I could use another provider. I know you guys don’t have enough motivation to really track down this issue which is what I’m going to give you by opening this complaint with TIO.
So I’m gonna wait for a call from you guys.

Regards,
Mohamed
Moderator

Hi @melsayed34,

 

We apologise if you feel that way. We will treat this as a complain and raise this to one of our Complaints Resolution Case Manager. We'll request for urgent case investigation on this case and you will be contacted via email or phone call once the assessment is done.

 

Let us know should you require further assistance.

 

Cheers!

Level 1a

Hi OP, Shane and others:

 

I'm still having the same issue in all of my computers (TPG - NBN Melbourne Area). The problem is related with the IPQoS and thethroughput. I found a solution that I will like to share with you (and help you with this frustration, I've been there):

 

In your ssh/config file, you have to add this line "IPQoS lowdelay throughput":

 

```

cat /etc/ssh/ssh_config
Host *
StrictHostKeyChecking yes
...
IPQoS lowdelay throughput

```

Then you need to restart your ssh service and it should work!

 

Hope it helps!

 

 

P.D: Sharn, it would be really nice if your team can fix this issue because it's pretty annoying to have to modify all my ssh config with that configuration.

 

Regards,

Cesar