TPG Community

Get online support

High Latency from Perth to SEA server - COD and Dota 2

Highlighted
Level 1c

Looks like its fixed.Looks like its fixed.

Highlighted
Level 1c

@hooch wrote:

Looks like its fixed.Looks like its fixed.


Unfortunately still getting 380 ping to the Singapore 1 Apex Legends server. Trace route still showing that it's being routed to Los Angeles before Singapore.

Highlighted
Level 1b
Hi I’m having the same problem too. Do u know how to solve it ?
Highlighted
Moderator

Hi @Thingyao,


Welcome to the community!
 

Thanks for raising this to us. If you’re in Australia, but playing on an American or Asian server, your latency will be higher because the geographical distance creates a delay between information being sent from an Australian client-side (player’s) connection before it’s received and relayed from the American server.

Connecting or Playing to a Game server not designated to your area will affect a high latency issue particularly if the Game Developer itself made a specific Server in every location such as SEA / NA Servers etc. If you're having latency issue while playing/connected to the Australian Server please post a screen shot of the latency issue and we'll have it check.

 

Highlighted
Level 1c

@Shane wrote:

Hi @Thingyao,


Welcome to the community!
 

Thanks for raising this to us. If you’re in Australia, but playing on an American or Asian server, your latency will be higher because the geographical distance creates a delay between information being sent from an Australian client-side (player’s) connection before it’s received and relayed from the American server.

Connecting or Playing to a Game server not designated to your area will affect a high latency issue particularly if the Game Developer itself made a specific Server in every location such as SEA / NA Servers etc. If you're having latency issue while playing/connected to the Australian Server please post a screen shot of the latency issue and we'll have it check.

 


Moderator don't talk about t hings you clearly don't know about. TPG engineers have already said there is an issue with the connection to SEA that's being worked on 'allegedly'. We had 50 pings before to SEA servers and now it's 300+ so don't try to say it's a geographical distance issue. Also other ISP's like Aussie BB, Telstra and Optus are not having these same issues and have the 50 pings we're supposed to have.

I'm leaving TPG shortly anyway due to this. 

Fed up.

Highlighted
Moderator

Hi @hooch, please PM us your TPG customer ID, username and complete address so we can pull up the account and help get to the bottom of this.

 

To send a PM, please refer to this link: How do I private message (PM) in the community

Highlighted
Level 1c

@Riezl wrote:

Hi @hooch, please PM us your TPG customer ID, username and complete address so we can pull up the account and help get to the bottom of this.

 

To send a PM, please refer to this link: How do I private message (PM) in the community


Hi Riezi I'd rather not. I've already called up tpg a couple months ago and lodged my ticket. Many others have done the same. All the information you need is on this chat and the similar thread on whirlpool. I'm leaving TPG soon anyways.

Highlighted
Level 1b

Still waiting for a solution for this. Been this way since May. 

 

2 Months with no solution? Well played!

Highlighted
Moderator

Hi @nelsv11, we had a look at your account and we can see that you have recently upgraded your plan.If we got this right, you're still experiencing the issue despite upgrading the speed. Is this correct?

 

If yes, we'd like to further look into this. May we know if the issue is time specific?

Highlighted
Level 1b

Hello @Riezl . 

 

Thanks for getting back to me. Yes, The account was upgraded last night when I called regarding this latency issue. I was told that nothing else could be done but my account was available for a free upgrade which I went through with.

 

As far as I see, the issue is still persisting and is not time specific. Its continuous and ongoing.