TPG Community

Ask, answer and talk about our products

How to get Xbox Live working on TP Link Routers

Level 3

If anyone is experiencing the UPnP error with Xbox Live when using TPG NBN and a TP Link router, the solution below should get you up and running.

 

The Problem

 

TP Link.png


Solution

 

DMZ.png

55 REPLIES 55
Level 1
Awesome post thanks. This works for me until I turn my Xbox off. When I go back on the following day, it no longer is connected. My Xbox in the IP address section gives a different address when it’s wireless as to when it is wired. Is this normal? I can only use the wireless IP address to get the wired connection to work. As I say the next day it doesn’t work again until I remove the Ethernet lead and reconnect or log back into my modem and re save the DMZ section. In the bottom picture below where you type the address it says to enable NAT function, where do I do this? I’m really frustrated. Having no issues with wireless connection at all.
Highlighted
Moderator

Hi @ehedges84,

 

This works for me until I turn my Xbox off. When I go back on the following day, it no longer is connected. My Xbox in the IP address section gives a different address when it’s wireless as to when it is wired. Is this normal?

Yes this is normal. The TPG router issues DHCP IP leases based on MAC address. The Xbox has a different MAC address for its Wireless and Wired interfaces. That is why your getting different addresses.

 

 In the bottom picture below where you type the address it says to enable NAT function, where do I do this? 

NAT is enabled by default. No need in setting this up. 

 

You would need to configure a STATIC IP address on your XBOX in the network settings and this should fix this issue.

 

Please configure an IP address outside of the DHCP range of the router e.g. 192.168.1.10. You also need to enter 192.168.1.10 in the DMZ configuration of the TP-Link router.

 

Static IP configuration Instructions can be viewed here - https://support.ubi.com/en-GB/faqs/000025508/Setting-up-a-static-IP-address-for-Xbox-One

 

Hope this helps!

 

 

Level 3
Hi,
I'm having the same problem and have tried the solutions you've suggested, but almost every time I go back to my Xbox after it has been in sleep mode, it is unable to connect to Xbox live. I have to hard reset the console to get it to connect again. I've tried port forwarding which has worked on every other router I have owned and it worked fine, but not here.
Moderator

Hi @Clowndamage,

 

Welcome to TPG Community!

 

May we know the error message that you received? Have you set your Xbox to have a static IP address?

 

Please provide us more information and screenshot of any error message that you received for us to analyze this further.

 

Kind regards,

BasilDV

Level 3
I have set up a static IP on the Xbox one. When it's not connecting it doesn't show up in the 'wired clients'. In my Xbox network settings it says all services are available, it just won't connect until I reboot the Xbox and it works fine.
Moderator

We're glad to know that @Clowndamage.

 

In case you will have queries in the future do not hesitate to open a new thread here in our community.
 

Let me know should you require further assistance.

 

Cheers!

Level 3
My issue still hasn't been resolved though?
Moderator

Hi @Clowndamage,

 

Can you post a screenshot of the error message for additional reference?

 

Regards,

Level 3
Sorry Shane I must be being unclear.
I don't get an error message. In network settings it says all services are available. But when I try to sign in it won't connect. Only after a hard reboot of the console will it connect and show up in the "wired clients" section of the router. But after putting the Xbox in sleep mode and returning to it later, it once again won't connect to Xbox live.