TPG Community

Get online support

Huawei HG659 - 2.4Ghz channel stopped working

SOLVED Go to solution
4377175
Level 2

HI, The 2.4Ghz band of my Huawei HG659 NBN modem router stopped working this weekend. The conenction has been dropping off once or twice a days for some time and now its not shown as an available channel at all.

But in the modem admin portal shows the channel as On and working,

I got a software upgrade on the modem done a few weeks ago thinking it would fix the issue and even did a factory reset, which didn't help either.

What else can I try and will I be able to get a replacement modem?

Both myself and my partner work from home everyday, so a stabel connection is very important and I have two laptops that only work on 2.4Ghz.

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
4377175
Level 2

Apologies for the late update. Received a new modem - TP-Link AC1600v.

Now the wifi is stable and availabel on both channels.

Thank you.

View solution in original post

4 REPLIES 4
Riezl
Moderator

Hi @4377175, we'd like to arrange one of our senior technical specialists to contact you for further assistance. Please send us a private message with your best contact number and most convenient time to receive a call. 

 

To send a PM, please refer to this link: How do I private message (PM) in the community

4377175
Level 2

Spoke to a technitian and dignosed that the modem is faulty. Then spoke to customer service and organised to send a replacement modem.

Will update the progress once the new one arrives.

Thank you.

4377175
Level 2

Apologies for the late update. Received a new modem - TP-Link AC1600v.

Now the wifi is stable and availabel on both channels.

Thank you.

View solution in original post

Riezl
Moderator

We are glad to know that, @4377175. Feel free to message us should you need further assistance. Cheers!