TPG Community

Get online support

TPG email account inaccessible with Thunderbird 78

John2125
Level 2

I am unable to access my TPG mail box using Thunderbird but I can with my web browser.  Last week I cleared my hard drive and installed Windows 10 and Thunderbird 78 email program.  Before that I could access my mail box with Thunderbird (and Windows 7).  The several attempts to setup and operate my account in Thunderbird have been unsuccessful.

When trying to get messages Thunderbird appears to try but downloads nothing.  When trying to send a message, it gives the message “Peer using unsupported version of security protocol.  The configuration related to mail.tpg.com.au must be corrected.”

How can this problem be fixed?

Thank you.  John.

25 REPLIES 25
PeterW
Moderator

Hello John2125,
Thank you for your message and for being a part of the TPG Community.
I need to get our Postmaster to assist you with this problem, for verification purposes can you please send me a private message (PM) by clicking on my name and provide the following information:
• Username
• Full Name
• Full Address
• D.O.B.
• Telephone No.
I will reply ASAP on receipt of the above.
Regards
PeterW
How To Private Message within the TPG Community:
https://community.tpg.com.au/t5/Welcome/How-do-I-private-message-PM-in-the-community/m-p/4093#M45
My TPG app for IOS and Android - https://www.tpg.com.au/download

John2125
Level 2

Hello PeterW.

Following discussion with TPG Postmaster the problem has been resolved.  However this was achieved by setting the Connection security to "None", which raises questions about connection security.

david64
Level 10

Hi John2125.

Here are settings from my Windows Live Mail client (Win7).

Outgoing mail (SMTP) Port 25, secure selection (SSL) ticked.

Incoming mail (POP3) Port 995, secure selection (SSL) ticked.

Just BTW, I use a freeware program called Wireshark which captures ethernet traffic on my computer. It shows the operation of SSL in this case.

 

david64
Level 10

Hi John2125.

Windows 10 Mail may be more flexible when connecting to mail servers than Thunderbird. In the post below, the TPG mail servers are the same server. For outgoing, ports 25 and 587 work the same with TLS. For incoming, port 995 uses TLS, not port 110.

 

Here is a post on Mozilla's help line:

My old mail account is POP3 only.

Incoming, POP3, mail.tpg.com.au, 110, STARTTLS, Normal Password

Outgoing SMTP, smtp.tpg.com.au, 587, STARTTLS, Normal Password

After many attempts Thunderbird 78 failed to add this new account.

After removing ver.78 an old ver.68 was installed and the new account was added without any problems on the first try using the settings shown above.

Does this indicate that Thunderbird v.78 is no longer compatible as a POP3 client or is this a serious bug?

Chosen solution

Probably not a bug.

But I believe I know the reason for this. Thunderbird 78 has stopped out of date use of SSLv3 and TLSv1. If server uses out of date insecure protocol then it's not Thunderbirds fault.

If you cannot connect using: port: 110 Connection Security: STARTTLS, then try 'None'

I have experienced a similar problem with a different server, all because server is not up to date on security protocol.

John2125
Level 2

Hi David64.

Does that mean the TPG postoffice is not up to date and therefore less secure with Thuderbird 78 than with earlier versions?

Regards.

John2125.

david64
Level 10

Hi John2125.

That seems to be the case judging by the Mozilla post and another TPG user last week:

Why is tpg still using  STARTTLS for email rather than SSL/TLS. In the new version of Thunderbird this option has been removed and therefore it's not possible to use with tpg's pop3 accounts anymore. Also Microsoft, Mozilla and Google have all deprecated the old security protocol.

 

Doesn't matter what it's called, looks like new Thunderbird is rejecting the use of SSLv3 and TLSv1.0 in favour of TLSv1.2.

I think I'll ask this question to TPG why they advise users to use no encryption; is it because their mail server is not using latest standard? (It may take a while to get a reply.)

David1010
Level 2

Hi david64,

I think the following link gives a workable  solution to the problem that Thunderbird v78 will not download or send TPG emails:

https://support.mozilla.org/en-US/questions/1295861

 

Especially see the comment by kotouc74 and also the comment by Wolfgang Scherer.

 

So, to combine their advice into one procedure that will work for the TPG servers:

In Thunderbird, select Tools, then select Options

At the top of the page, in the Find in Options search box, enter “Config Editor” and the hidden link to the Config Editor should show. Click on the link.

 

Note the warning “This might void your warranty!” and click on “I accept the risk!”

 

Search for “security.tls.version.min”, double click and set value to 1

(Default setting is 3 if you ever need to back track)

 

Search for “security.tls.version.enable-deprecated” double click and the setting should change from “false” (default) to “true”.

 

With TPG, I’m using Port 110 to connect with the POP mail server and Port 587 to connect with the SMTP server. For both servers, the Connection Security is set to STARTTLS.

 

With the above settings, while TPG email encryption is not happening at current “best practice” due to TPG policy, it is no worse than before. Also, it is considerably better than one TPG suggestion of setting Connection Security to None.

 

I agree the best solution is for TPG to update its encryption protocols to current “best practice”.

 

odyssey
Level 2

Thanks, that has worked except I now have to put in my password to sent any emails.  Hopefully TPG will update the security to match Thunderbird and other software.

Cheers

Ton

Ahra_G
Moderator

Hi @odyssey

 

After the recent update of Thunderbird, there were few posts having common issues about not being able to send/receive emails. 

 

We have created an article which helped resolve the common issue:

Thunderbird ver 78.1.1 and above Troubleshooting

 

Hopefully your issue gets sorted using the article above. 

 

 

Let us know should you require further assistance. 

 

Regards,

Ahra_G