TPG Community

Ask, answer and talk about our products

USB Drive Sharing with Huawei HG659 - Solved

SOLVED Go to solution
Level 1c

Three days ago my NBN HFC connection was installed and I fired up the TPG supplied Huawei HG659 and the Internet and VoIP worked immediately.


I have been using a USB drive as a network attached storage on my old router and have found it really useful for LAN sharing of files.


Unfortunately I plugged my USB drive into the HG659 and set up the SAMBA server as per the TPG/Huawei instructions but I could not access the drive through the network.


The problem is that SAMBA (and FTP) do not have a default Access Control List (ACL) setup by TPG and this requirement is not made clear in the instructions.


Firstly plug the USB drive into a USB port on the HG659 and log into the setup utility.  Setup the SAMBA server in the Sharing section, add a user name and password, drive and permissions as per the HG659 manual. (Sharing section)


Setup an Access Control List for the SAMBA server to access the LAN as follows:


Open the Internet tab in the HG659 setup page

Select network Security Tab

Select ACL

Select +New ACL

In Service Type select SAMBA

In Access Direction Select LAN

Click Save.



In Windows file explorer, right mouse on network

Select map network drive.

Select the drive letter required.

In the folder text box enter: \\\username then click Finish (username is the username that you set in the usb storage user part of HG659 user settings. Note that if you have changed the HG659 LAN address, then change the \\IP address\ part to be the same as the IP used to log onto the router)

The security dialog box should open:

Enter the user name (for the usb storage)

Enter the password (for the usb storage)

Click OK and you should now see and be able to access the USB drive


The same ACL setup is required to access the FTP.


Level 3
Let us know how it goes.
My 3 TB NTFS-formatted USB Removable HDD is also not working as file share :-|
Enterprise Administrator
Level 1

I had to reboot the router after doing this and up it came as per the instructions above  -  2tb USB drive available 

Level 2

Have tried all that with no success, have they crippled it?

Level 2

Scratch that, the procedure works but I had to reattach my USB drive afterwards for some reason.

Thanks all.

Level 1a

My router connected to an old XP computer and after following the instrauctions I cannot see it in the network places, but I can see it on a Windows laptop also connected to the network, but it won't let me log in using the login details I entered ;(

Level 1a

Thank you man.


That's solved access to my USB hard drive.



Level 1a

you are legend 

this instruction is worked!!!!!

Level 2
Level 2

My HG659 uses SMBv1 which is no longer installed in Windows 10 because of poor security. To access the USB drive from my Win10 machine I had to activate SMBv1.


The instructions are here:



Level 1b

Just tried this on my HG659 but could not find ACL in Internet - Network Security. Only 3 topics there, Firewall, DMZ and Application Filter (which sets up blocking for selected apps on selected devices). Maybe because my modem was supplied by iPrimus, not TPG?

Had a couple of breakthroughs and now working on my PC.

Note- I am using Windows 10 Pro. Tried it with my laptop using Win 10 Home - doesn't work.

First, must login with full admin privileges. This requires username which is last 4 digits of serial number plus last 4 digits of Mac and password which is the @ sympbol followed by last 6 digits of S/N plus last 6 digits of Mac. Now can access ACL and add samba.

Next, must activate smb on Windows 10 PC. Press Windows key and R on keyboard. Type in optionalfeatures.exe and press enter. Expand smb 1.0 CIFS and tick all boxes. Restart when requested.

Continue with webbpj's excellent directions and should work.