TPG Community

Get online support

Apple devices can connect to WiFi but no internet

Level 2
I just switched from Telstra NBN to TPG NBN today. My MAC, iPhone XR and iPad Air all can connect to WiFi (2.4G and 5G) but no internet at all. Tried wired connection and WiFi on a windows laptop and both ways work fine. Looks like WiFi of the TP-Link router (Archer 1600v) has poor compatibility with Apple devices. Also tried using 802.11n or g/n only. Worked for a few minutes and then no internet again. Very frustrated.
Level 15

This is from Apple support. Is it like what you get?

Check for issues with your Wi-Fi network

If iOS detects an issue with your Wi-Fi connection, you might see a Wi-Fi recommendation under the name of the Wi-Fi network that you're connected to. For example, you might see the alert "No Internet Connection". To get more information, tap the Wi-Fi network.


Also check that the Apple device still has an ip address.

Do the Apple devices get good signal strength?

Check the system log on the wifi router.