TPG Community

Get online support

Archer VR1600v V2 Firmware

Level 2

Ive been having recent connectivity and system stability issues with my router and as part of the troubleshooting thought I would check if I have the latest FW. At times I can't connect to the management webpage of the router, and only effective fix is a power reboot.


I called TPG support who referred me to TP-Link who have referred me back to TPG again.  


Could a moderator assist in confirming if I have the latest build available and if not could TPG support assist with generating an update?  

Current Build is:  

Firmware 0.1.0 0.9.1 v5006.0 Build 200810 Rel.53181n

Hardware Archer VR1600v v2 00000000

Level 15

Hi @dmurf . Build 200810 is the latest firmware.  TPG shouldn't have referred you to TP-Link because the VR1600 is a special for TPG. TP-Link don't support it.

Have you tried doing a factory reset, not just reboot? You may have to re-enter the config details if it doesn't auto-configure.

When you can't connect to the management page, does the browser page just time-out, or an error message?

Is the internet still accessible?

Are you using wifi device or ethernet computer?

If you have a computer the next time you have the problem, do:



Level 2



I did try pinging the management address and it worked, from a cable connected laptop.


Wider symptoms are:


1. can't access the management page, either from wifi or cable connected endpoint

2. a device previously connnected by wifi won't get an dhcp IP address from the router, I then added a manual address and still could not get internet connection, I've seen this behaviour across multiple. Seems to authenticate ok.

3. I then deleted the wifi settings on the end device and attempted a new connection, fails again to get an IP address and defaults to the 169. Address on timeout. After reboot works.

4, other devices connected worked as usual including internet throughput

5. speed throughput drops significantly for devices that remain connected

I have a total of about 15 or so devices wifi and 3 cable connected at any one time. 


Things I've tried.


1. initially changing wifi channel of 2.4g range 

2. loading devices equally acrosss the 2.4 g and 5G ranges so that there was less traffic within a specific band

3. reboots which fixes it initially. Seem to need to then do this every couple of days

4. ensured no logged turned on in the router in the event it was impacting.

5. checked dhcp scope and I have an address pool of 150 addresses set up.


re the referral to TP-link that was the answer they gave me, saying it was provider supported.

haven't tried a factory reset as yet, will give that a try today and monitor. Overall I would prefer to use my nighthawk router but can't get the same internet speeds for some reason. I had a previous post about that but no joy.

Level 15

@dmurf . 

Next time the VR1600 fails, try this from the cabled laptop in a command window:
telnet 80
The window should clear. Press Enter. You should get the following, then back to command prompt.

HTTP/1.1 400 Bad Request
Content-Type: text/html; charset=utf-8
Content-Length: 110
Set-Cookie: JSESSIONID=deleted; Expires=Thu, 01 Jan 1970 00:00:01 GMT; Path=/; HttpOnly
Connection: close
<html><head><title>400 Bad Request</title></head><body><center><h1>400 Bad Request</h1></center></b
Connection to host lost.

If you don't get this, the management program is broken. Might be caused by a hardware fault or some odd condition not handled properly which causes the dhcp function to not work (would a cabled computer fail to get an ip address or only wifi?) and causes speed drop.


Regarding the lower speed of the Netgear, can you check:
MTU value
Bandwidth control in Archer: is it enabled and are there any values?
Quality of Service in Netgear: disabled by default.

I saw your post from last year. The higher attenuation on D7800 might cause the slower synch rate and be enough to drop the speed test results.
At this point, you might decide to take it up with Netgear, why the D7800 is slower than the Archer on the speed test. The speed test on the TPG support page shows a progress graph which might be informative. Netgear would need the DSL info from both routers and the two speed test results.


If you want to keep going, you can try this comparative testing. Use the cabled laptop; wifi response times are too variable.
tracert -d
Do ping to the address on the second line. It should respond. This is the address to use for manual throughput testing.
In the ping command, use the -n parameter to repeat enough times to get a steady state response time; try 10 initially.
The length of data in the ping can be set using the -l (lower case L) parameter; default length is 32 bytes. The idea is to compare the response time through each router as it processes longer messages.
(When I did this, sometimes the first ping had a quite long response time. There was a delay between two frames arriving at my laptop. But I don't know where or why.)
In the ping command, omit -l gives 32 bytes
-l 1460 is one frame
add multiples of 1460 to increase the number of frames
or, just do, say, default length, then 1460, then 5000, 10000, 20000.

Level 3
I've currently got an earlier build then mentioned in this post. How can I get a hold of the latest firmware file?

My version is:
Firmware Version:0.1.0 0.9.1 v5006.0 Build 190228 Rel.72265n Hardware Version: Archer VR1600v v2

Hi @Mr_Pickle


Please send me a PM with your TPG username or customer ID number for us to forward your request.



Level 2

Hi BasilDV,

I have similar issue. Would you be able to assist in getting the latest firmware?


Hi @justanna,


A firmware update may or may not fix the connection issue hence it's best to check everything service-related to ensure that the issue won't reoccur. 


We'd be happy to perform troubleshooting along with you and assist with the firmware update. Please send your Customer ID/username via private message so we locate your account and run remote tests on our end. 




Hi BasilDV,

I have similar issue. Would you be able to assist in getting the latest firmware?

Level 2

Hi @Ahra_G 


I also need the latest firmware update but can't see the "Send a message" button anywhere when I click on your profile name ..?


It looks like I don't have permissions to send a private message ??



Level 2

I can see it now Smiley Happy