TPG Community

Get online support

Connecting to smart home device from outside the home network

Level 2

I'm trying to connect to my smart home device from outside internet through my static/dynamic IP but thus far havn't worked it out. Any advice would be great.


My setup is as follows,

TP-Link archer modem

Then connecting internally to TPLink Deco X60 wifi system

Which is hard wired to my Smart Home device. (This is a clipsal shac 5500 to control my home lighting)


My internal ip is in the range to


My archer modem is and has an internal IP in it's Virtual server settings. 

The archer modem Network > LAN settings reserves which is the outside address of the Deco X60 (it is also seen in the client list of the modem so I know it's conected)


In the Deco X60 I have setup port forwarding from to the internal IP address of my Clipsal smart home device 192.168.0.XXX:80


I thought this was the way to setup the port forwarding through both of these devices but it's not working... Any ideas as to how it should be setup?








Hi @psionic001 . What model Archer is it? And what type of NBN connection?

Do you use VOIP? If not, you might be able to do without the Archer (depends on type of NBN connection.)

Is there a reason for connecting Shac to X60 rather than direct to Archer?


Like to suggest a change to config. (I don't know how having 2 subnets works.)

Archer has ip of 

In Archer, assign a fixed ip to X60 of (which you have). And for Shac.

In X60, set its address to and disable DHCP.   DHCP is done by Archer.

Connect Shac to X60 and see if Archer recognises Shac and gives it the fixed ip address.

(Want to see if X60 passes the Shac mac address to Archer.)

In Archer, set port forwarding to Shac ip address.


Do you have static or dynamic WAN ip address?

If dynamic, you should setup Dynamic DNS so you don't need to worry about your WAN ip address changing.


@psionic001 . To disable DHCP, in Operating Mode screen, set to Access Point. This disables some other functions as well.

Level 2
Thanks David.
Yep, TPLink suggested I switch the Deco X60 to access point mode so I only have one port forwarding to conduct. I’ll try it today.
They did suggest that TPG might limit the ports that can be found/seen, which may also be causing the issue.
Level 2

Good luck with that, buddy. I had the same problem when I set up my smart house. It took me forever to find a specialist to solve my problems. However, of all my intelligent items, only the smart light bulbs from amazon remained connected. I didn't have trouble with them. I paired my phone with them and vouillé. I remember all the intelligent items come with a controller, so maybe you'll manage to set it and make it work or link all of them to a google home box. Maybe it will work for you; let me know if you solve it.