TPG Community

Get online support

Netgear NightHalk R9000 to work with NBN

SOLVED Go to solution
Level 3

I have phoned TPG got all the necessary info I needed to hook up my r9000

TPG said that's ALL you need to login

Username, Password, VLAN ID 2

I have tried everything and have hard reset my r9000 10 times cause it keeps loosing IP address.

I've even logged into the original router and found that's not ALL you need.

copied every setting down. and still, no connection, losing patience... and need some help.

Every time someone has a problem and they fix they're r9000 they never tell you how they fixed it... that's just weird. So Im here to ask for help.

Level 15

What type of NBN connection do you have?


Have you looked at the manual?


Logon to router. On BASIC screen, select Internet.

You require a login, select Yes.

Encapsulaion is PPPoE.

Enter TPG username and password.

Connection mode, select Always on; timeout 0 minutes.

Internet IP Address radio button: Get Dynamically from ISP.

Domain Name Server (DNS) Address radio button: Get Automatically from ISP.

Router MAC Address radio button: Use Default Address.

Click Apply.


Regarding VLAN ID 2, you need to look at the manual. There is a section on P66. If your router has ever worked at all, this must be correct. Otherwise you need to add/edit a vlan group, call it Internet, vlan id 2, priority 0, wired ports ALL (or select all ethernet ports), wireless ALL (or select all wireless networks), tick Enable, then Apply. (Only guessing here; depends on what is in router by default.)

Level 3

I have used every combination possible after 20 times hard resetting my r9000

Netgear support didn't know what he was talking about. only one thing he might be right about was asking TPG to register the MAC Address of my R9000. I also had an issue with my IP Address a while ago, and TPG may have changed settings.


After not working for me I looked into the old router settings and found a different user name and password that what TPG had given me to setup my router

1. Put in my user and pass in / Always on / cant change timeouts unless changed to other setting then greys out again.

2. everything on Automatically get / Default MAC Address / tried old routers MAC (didnt work)

3. Made new VLAN ID / entered name (cant enter Internet as is being used already) /  2 for ID / priority 0 / selected all ports and wireless (cant select 60Ghz as its being used (tried only selecting port 1 only) didnt work

3. IGMP Proxy (unchecked disabled)

Level 3

I don't even know when I can use my router, been on the phone today with Netgear and TPG at the same time - TPG 5.23hrs - Netgear 2.45hrs. hung up on TPG after I spoke to Netgear.


So bought this router and setting it up at the worst of times, if I need support... with the coronavirus influencer.

Level 3

I fixed my router, this is what I did.

I uplugged my internet from the router and left the Ethernet to the computer only

Login to router –


I. Advanced tab – Setup tab – Internet Setup

  1. Clicked radio button - Dose your Internet connection require a login
  2. Login (as username)
  3. Password
  4. Connection mode - Always on
  5. Idle Timeout – 0
  6. Apply and wait

II. WAN Setup. tab

  1. Disable SIP ALG (put tick in box)
  2. Disable IGMP Proxing (no tick in box)
  3. Apply and wait

III. LAN Setup tab

  1. Clicked +Add (should pick your computer auto)
  2. Apply and wait

IV. Advanced Setup

  1. Clicked VLAN / Bridge Settings
  2. Enable VLAN / Bridge group
  3. By VLAN tag group
  4. Clicked radio button on default vlan ( already made) and Edit
  5. VLAN ID – 2 (rest should be on all)
  6. Click Apply  (click Apply again) 2 times
  7. Plug the internet cable into the router

Had a lot of trouble with this setup, maybe because I bought a second hand router from overseas. I needed to do the steps in order, otherwise I would always lose my IP Address on my router, I couldn’t log into the router and needed to hard reset router.

Level 2

I made an account to say this... 2 years later and this is the only information that worked for me. I've been looking for 5 hours to figure this out. Thank you, kind person.