TPG Community

Get online support

Nginx port forwarding problem

djboob1966
Level 2

Hi I'm trying to set up a home network and I keep having problems with the ports forwarding I'm trying to forward ports 80 and 443 for Nginx using a pi4 the problem is when I add my public IP and port 80 eg

123.123.123.123:80 it always takes me to the router remote management page. I have a nighthawk D7000v2 modem I have done a reset and once I set up internet then nav to the remote management tab the public IP is now my remote management IP with a port how can i stop TPG adding my Public ip as the remote management I have tried turning off remote management and changing setting but still with no luck.

so is there a way to stop this happing?

 

8 REPLIES 8
david64
Level 10

Hi @djboob1966 .

I had to look up what NGINX is and it is a web server which is why you're trying to forward port 80 and 443.
It will be running on a Raspberry Pi4.
I don't understand your problem with remote management. Are you wanting to use remote management?
Are you saying that you do factory reset and remote management is already enabled?
If there are already entries on the remote management setup page but it is not enabled, maybe that's how the router works. You can test this. Do a factory reset, do the internet setup, find your public ip address, use your phone's mobile data and browser to access your public ip address and port 80: http://publicipaddress:80     It will timeout because the router won't accept it.
Port forwarding is only used if you want to access your network from the internet. Otherwise, all your local devices can see each other. Do you want to access your home network remotely?
TPG have no control over third party routers.

djboob1966
Level 2

I using Openmediavault and docker on the pi and I wish to have nextcloud as well as WordPress as a container I need Nginx to forward ports to them I tried it on my phone and it opens my modem/router login page I'm following this guide https://www.youtube.com/watch?v=UoABJxIeq3A on youtube at the end if you place your public IP and port 80 it opens a page saying "congratulation you've successfully started the proxy manager"

16.58 of youtube guide

when I go into the modem setting remote management is unticked but I can still get remote access i wish to turn this off but can't so it always open the modem/router login page. 

david64
Level 10

@djboob1966 .

I tried this on my mobile phone to my Archer VR1600 and I could reach the login screen of the router. IMO, that's a bug. If the remote management flag is unticked, the router should not respond to connections on any port. If there is no port forwarding rule, the router should just ignore the connection. Strange that two different brands do the same thing. I tried some other random ip addresses but couldn't find another one showing the router login screen.
An easy workaround is to define a forwarding rule for port 80 and 443. I forwarded port 80 to my computer and then no more login screen on my phone. Windows sends back RESET frame and browser shows Connection Refused straight away. Port 443 seems to work according to the rules. I couldn't connect to the router on port 443 using http or https.
The Pi4 needs a reserved local ip address. You need to set up DDNS to access it from the internet.

djboob1966
Level 2

@david64 

"I tried this on my mobile phone to my Archer VR1600 and I could reach the login screen of the router."

If this is right and you did the same is this, not a security risk if so that's three diff types of modems that behave the same. Is this something to do with TPG service?

david64
Level 10

@djboob1966 . I've opened a new thread on this problem with TPG on Archer VR1600. I'll find out whether it is a firmware bug. Could be because many router makers use the same GPL router code. You could try raising this problem with Netgear.

djboob1966
Level 2

ok, I just installed Nextcloud and when I enter the DNS name nextcloud.xxxxdjbxxxxclick.com link in Nginx it still take me to my modems login page.

david64
Level 10

@djboob1966 . Did you get a VR1600 router from TPG? If so, can you do a test with this. Forwarding port 80 to your computer stops the router web page showing. Your public ip will change with the new connection.

 

djboob1966
Level 2

No, an HG659 also did a test on a D7000v2 Netgear will test a tp-link modem tonite Archer D7 but so far it still opens modems login page with public ip and port 80