TPG Community

Get online support

TPLink Archer VR1600V USB Sharing

Level 2

Hi Team


I am trying use USB Sharing on my TP Link Archer VR1600V for the first time

1) USB is plugged in

2) On Managament console USB is scan succesfully and i can see Used and Available Space

3) I tried 2 USB ( FAT and NTF)

4) I tried on IOS (MAC) , WIN10 and WIN11

5) Problem is - USB appear on Network but it opens up on below address. Some details are masked

i called TPG and they did some reset but still facing the problem

current firmware is below


Firmware Version: 0.1.0 0.9.1 v5006.0 Build 190228 Rel.72265n
Hardware Version: Archer VR1600v v2 00000000

MiniDLNA status

Media library

Audio files0
Video files0
Image files0

Connected clients

IDTypeIP AddressHW AddressConnections

0 connections currently open




Level 15

Hi @6886946 . Part of your problem might be explained here.

VR1600 might be in same boat as C1200.


There's also the problem of 2GB file size limit.


Have you read the TP-Link user guide for VR1600? It explains the access methods for USB storage. The real device may not function exactly as explained in the guide.

Level 2

Thanks David

I tried on MAC, WIN10 and WIN11.

For Win11, SMB 1.0 CIFS Client and CIFS Automatic Removal is already checked and only CIFS Server is unchecked. To me this looks fine




Level 15

@6886946 . My VR1600 is on build 200810 (later than yours but doesn't have the VPN server function). My computer is Win7. I've used a flash drive in my router before but can't remember anything special about it. I've put a 8GB FAT32 drive in now and using Wireshark to see what Win7 is doing. Win7 is sending SMBv2 requests and VR1600 is responding with same.

Can you get it working with Windows Explorer? Put   \\   in address bar. Archer will show up under Network. VR1600 opens port 445 for this function. You can telnet to this port to see if it is open but can't do anything with it.