TPG Community

Get online support

TPLink Modem VR1600 weird behavior

Level 15

@Taz . Build 200810 is latest but there is a possible build 210413. Don't think that's the issue.

Router can only test the internet connection. Your computer can do pings just as well.

Have to see what TPG says. They can test better. Either see if they answer this thread or create a new one. Add the extra steps you've taken.


Hi @Taz


Thanks for raising this with us.


The firmware of your modem/router is the latest one available.


Do you experience the issue at a specific time or it's random?

Have you tried to factory reset the modem/router?


Are you using a WiFi or a Wired connection?



Level 3
Level 3

Well this morning when it did it on my PC (ethernet), my mobile phone stopped working too (Wi-Fi to modem). I had a terminal program on it pinging So connectivity to the modem is fine, but the modem loses packets or something stopping all Internet. Seems to do it more often after restarting the computer, but that doesn't make sense that the PC can retain connection to the modem but internet dies... modem diag reports it dies... phone stops working... Nothing appears in modem log file.

Not keen on a factory reset, it's painful putting all the settings back in. But sounds like it might be the next course of action.

Level 3
Level 3

Ok @BasilDV thank you for getting back to me. Here is more info. Problem still unresolved.


1. Happened on Windows 10, X99 motherboard Xeon cpu.

2. Upgraded computer to Z690 intel gen12, realtek 2.5Gbps NIC. Still happened.

3. Upgraded to Windows 11 (keeping settings). Still happened.

4. Fresh install Windows 11. Still happened.

5. Factory default of modem. Still happened.

6. Changed NIC to Intel 4 port NIC known to be working well and reliably elsewhere. Still happened.

So everything has been changed now except for the modem.


Restarting computer seems to trigger it, about 5 mins after the computer starts, there is a period where the internet drops, the comes back, then drops. Numerous times over at least 1/2 hour, lose internet for several minutes at a time. Although the computer is somehow triggering it (through wired lan), Wi-Fi link from modem to mobile phone also stops working. Modem diagnostics from the admin screen also stops working. - this is the modem performing DNS lookups, have tried TPG DNS as supplied by DHCP and also statically defined. Modem DoS protection is turned off. 


On another note, I also tried enabling https admin and firefox complains about it not support TLS1.2. This implies really old firmware is being used and is probably very susceptible to having been hacked, which is what I am considering now. A PC shouldn't be able to cause a modem to lose internet access, especially when the PC does not lose access to the modem. I am wondering if TPG has DoS or other protection being tripped or something? What modems are you dishing out these days? I think a replacement modem needs to be tried next if TPG logs don't reveal anything blocking.

Thank you

Level 3
Level 3

Hello @BasilDV . Factory reset did nothing. I borrowed a different brand modem. Exact same problem.

I have however worked out the issue. My firewall (Sophos XG) causes the issue by doing DNS lookups directly to or When I use an internal caching DNS server or use the modem for DNS server (which uses TPG DNS servers) everything works almost perfectly.

Is TPG filtering my traffic so that when it gets a large number of DNS queries (which happens when a firewall starts) that you are flagging this as suspicious activity and interfering by dampening or blocking traffic? If you aren't, someone else is. Unfortunately, it takes my internet out for 10 minute periods and its been getting worse and worse lately (more frequently and for longer periods). 

So if you are doing it, can you please lighten the rules a bit, they are over restrictive and flagging us as a false positive and being very disruptive to my service.

Can we escalate this to high level tech people for investigation please?



Thank you for the update @Taz


We've tested the line and was not able to detect any fault, which means that the possible cause is the modem/router.


Your device is already out of warranty, but we've sent you a PM and will wait for your reply to progress it.