TPG Community

Get online support

Wifi Connectivity Issue to One Device (Surface Laptop)

Level 2

Hi Team,


Last month I got the TPG 5G Home Broadband Max connection and everything is going fine except a surface laptop wifi connectivity issue.

I have attempted several troubleshooting steps (Resetting modem and Resetting device network settings) and nothing helps.
Once it was connected when I tried it as an open network and now It is not getting connected to that one too.
As it is my office laptop I have checked with my IT support team and there is no issue with the device or device settings.
I am wondering how that device is not connecting to TPG and connecting to all other networks. And also all other devices are able to connect with TPG.
Any help would be greatly appreciated.

Hi @djayaraj . Does the laptop see both home wifi networks? Good signal strength?

Considering your other devices, which wifi network do they connect to?  All on just one or spread over both?

Does the 5G Home router do band steering? That might affect the laptop.


Level 2

Hi @david64, Thank you for the reply

I am receiving a good signal on my surface laptop

I have attempted with and without band steering. And I have tried with default SSID and credentials and also with custom SSID. No success. 

Other connections spread over both. 


Note: The device was not connected with the iPhone hotspot when the 'Personal Hotspot Not Discoverable'. Like that any settings need to be changed on the modem?



@djayaraj . Does the laptop fail to connect to the wifi, or, does it connect to wifi but fail to get an ip address?

Anything to do with the wifi security (WPA2)?

What model router is it?

Can you check the router system log; any messages when the laptop tries to connect?

If you turn off one device using the same SSID as the laptop, does it connect then?


Level 2

@david64, Yes the laptop fails to connect to the wifi. Receiving error on the device 'can't connect to this network'.  

Security has two options only. 'WPA2-WPA3-Personal' or 'None'. Attempted with both options and had no success.

Modem Model: Sagecom Fast 5866T

I hope no such logs are related to this issue.

If you turn off one device using the same SSID as the laptop, does it connect then? No.

I have restarted the device and modem several times and reset the modem a few times too.


@djayaraj . I meant the system log maintained in the router. Any messages around the time the laptop tries to connect?

On the laptop, do     ipconfig/all    and compare it with another wifi device that has connected.

How many ip addresses in the router's dynamic pool?


From internet search:

Advanced troubleshooting: Check to see if MAC address filtering is enabled

Wireless routers can prevent unauthorized network access by using a feature called MAC filtering.

Unfortunately, MAC filtering can also prevent your Surface from connecting to your wireless network.

If MAC filtering on your router is turned on, try one of the following:

  • Turn off MAC filtering temporarily to see if that is preventing your Surface from connecting to your wireless network.

  • Add the MAC address of your Surface to your router’s authorized list. (Do this anyhow.)


@djayaraj . Can you make the laptop forget your home network, then reconnect and re-enter the wifi password.

Level 2

@david64, The network is not stored with the device. That option is ruled out. 

Level 2


this fixed my problem. sadly I bought a new laptop before I found this solution. sp3 was kinda old and slow.