TPG Community

Ask, answer and talk about our products

You got to be kidding me. Complained about 5Ghz speed on a AC1600 modem and got a N300 replacement

SOLVED Go to solution
Level 1d

So here is the back story. Complained on FB about slow speed and a tech visit was quickly arranged.I was actually impressed with the quick response. The tech said it is the building's wiring issue. I also showed him the 5ghz on Archer VR1600v is pretty slow. So got a call couple of days later to troubleshoot the router and it was established that a replacement is needed. So far so good...

 

A few days back the router arrived but I opened it only today and lo and behold.. I was shipped a N300 2.4ghz modem as a replacement, to replace a AC1600... a freakin N300. I was surprised that it is even an option as a replacement, for any type of modem/router. I completely lost it and customer care told that I would get a call back tomorrow.

 

Is this something that usually happens? I can understand if a AC1600 is replaced with a AC1300 or a atleast a dual band device, but a N300 is beyond pathetic. Aren't these things even checked or at least checked with the customer before shipping it? 

9 REPLIES 9
Moderator

Hi @vkharibabu

 

I reviewed your case and it appears that you were provided a TP-Link TD-W9970 which is for an ADSL service. My apologies for the incorrect equipment sent. I can see though that you have spoken to our Engineering Team earlier and that this has been raised to the Case Manager to send the correct replacement. As discussed earlier, please wait for an update from your Case Manager.

 

Regards,

Moderator

Hi @vkharibabu

 

On another note, I already took the liberty to raise the modem replacement on our end instead. We'll let you know once we have the consignment details.

 

Regards,

Moderator

Hi @vkharibabu

 

I can see that you were contacted by our Engineering Team informing you that the modem has been delivered. Leave us a comment if you need further assistance.

 

Regards,

Level 1d

@Will yep, received the modem today and I have verified that it is a VR1600. However I would be able to set  it up only on the weekend, so will report back if Ihave any issues. It is a shame though that TPG has locked out the option to backup/restore the settings. (for someone with 8+ dhcp reservation, which again has to be added with mac address is a pain in the a$$)

 

I will return the N300 in the satchel that came with it, and the fault modem in the satchel that came with the new modem after setting up the new modem (just so that they pick up both in one shot). 

Moderator

Hi @vkharibabu,

 

Thanks for confirming that you have already received the correct modem replacement.

My apologies though if the current firmware doesn't support the backup and restore feature. Nonetheless, should you have other concerns, feel free to drop by.

Level 1d

So, I got the new modem setup and everything seem to be in order. I just managed to get the bare minimum in place to get the internet going, and so far so good.

 

I will ship the faulty router back on monday. On the N300 router that was sent by mistake, I seem to have packed it into the satchel without removing the "Interim Despatch summary report". It has a driver copy and sender copy, so I am assuming that the driver has to sign it when he picks up the parcel. Could you mail me a copy of this for the consignment number 7KGZ00006049?

Moderator

Hi @vkharibabu,

 

Since it is a post pack, the sender copy will be your copy.

 

There's no need for an extra copy.

 

Regards,

BasilDV

Level 1d

Great.. Had no issues getting my faulty router picked up. cheers mate.

Moderator

Glad that it's all sorted now, @vkharibabu

 

Don't hesitate to shoot us a message should any additional assistance arise. 

 

Cheers!