TPG Community

Get online support

connecting ASUS RT-AC66U-B1 to NBN

Level 1c
am trying to connect ASUS RT-AC66U_B1 to NBN50,

replacing Netcomm NF7.

i tried set VID to 2 from LAN - IPTV - Manual Settings.

also try set the profile to TPG aswell but still not connecting,
switch back to Netcomm NF7 works

wondering do i need to leave disconnect for x amount of time for server to timeout before reconnecting?
does username require domain?

anyone using similar model can assist? graphical screenshot of your settings would be helpful.


Hi @trangmyto 


Welcome to the Community!


If you are using the Netcomm NF7, then it means that the NBN technology you have is FTTP (Fibre to the Premises). For this type of technology, you don't need to set the VLAN ID to 2.


Make sure that your device is running on a 'Router only' mode, then configure the PPPoE with your TPG username and password. Make sure that you have the correct UN and PW by logging in here.


You may use this article as a guide: How to set up TP-LINK C1200 modem for Windows 10


Stay safe,


Level 1c
so it simple just username and password, and if its not connecting?

do you need to do something at your end ?

can you tell me what type of NbN if im running huawei HG659? i plan to test it on another premises using that modem

(the NBN modem is different, i am guessing it different technology?)

Hi @trangmyto 


I've responded to your other post.

You'll be able to check the type of NBN technology you have.


We do not need to change anything from our end when customers are using their own third party device.