TPG Community

Get online support

i have ssh problem with tplink VX-420-G2v.

stevenhkwong
Level 2

i have ssh problem with tplink VX-420-G2v when i try to ssh out onto the internet.

Firmware Version:2.0.0 0.9 v603c.0 Build 210817 Rel.48355n Hardware Version:VX420-G2v v1.0 00000000Support

Is there a new version of firmware that can fix the problem.

 

Please see this work around in https://serverfault.com/questions/692026/cant-complete-ssh-connection-after-successfully-exchanging-...
Which suggest ssh with -o IPQoS=0. There seems to be a bug in the firmware

with tplink router.

 

New firware from tpg to fix the issue?

 

Steven

 

 

 

 

 

 

 

 

6 REPLIES 6
david64
Level 12

Hi @stevenhkwong . Have you done packet capture to analyse this problem?

 

Does your VX420 have bandwidth control function? Is there a value for upload speed? 

When you do the TPG speed test, does the graph proceed smoothly during upload test? If it doesn't, setting a value for upload speed might help. Value depends on NBN plan speed.

NBN relies on CPE to self-regulate and not transmit too fast or for too long.

 

Regarding QoS, there's no manual for this router. Going by the VR1600, you can set policies but this may reduce the general throughput speed. 

Does  -o IPQoS=0  make ssh send at full speed rather than pacing itself? 

 

stevenhkwong
Level 2

When I had the issue, using -o IPQoS=0 does fixed it. I didn't do any packet capture as I think it is a router issue. The problem is not there when I connect out using my phone as a hotspot.

 

Strangely enough my problem seems to have dissappeared today. ssh now works without the IPQoS option.

I still think it is a router issue though as this only started with the new tplink vx-420. I didn't have this issue my old HuaWei router.

Afraid I don't know what OPQoS=0 but all that I have googled points to the vendor needing to fix their firmware for it.

 

 

david64
Level 12

@stevenhkwong .  On further reading, found this.

You can put   IPQoS=0   option in the system-wide config file:    /etc/ssh/ssh_config

There are standard values for interactive use and batch use (scp). The router checks this field in the frame to prioritise traffic. The router should just ignore the field if it doesn't support the function.

Some routers support 802.11e/Wifi MultiMedia. Strangely enough, the datasheet for HG659 has this for QoS:

Rate limitation
Upstream traffic classification
Priority queue

 

Shane
Moderator

Welcome to the community!

 

Thanks for bringing this to our attention, @stevenhkwong. We will raise this to our Network Engineering Team for investigation.

 

Please drop me a Private Message with your account details (Username/Customer ID together with the address on file).

 

How do I private message (PM) in the community

 

Regards,

 

 

i have ssh problem with tplink VX-420-G2v when i try to ssh out onto the internet.

Firmware Version:2.0.0 0.9 v603c.0 Build 210817 Rel.48355n Hardware Version:VX420-G2v v1.0 00000000Support

Is there a new version of firmware that can fix the problem.

 

Please see this work around in https://serverfault.com/questions/692026/cant-complete-ssh-connection-after-successfully-exchanging-...
Which suggest ssh with -o IPQoS=0. There seems to be a bug in the firmware

with tplink router.

 

New firware from tpg to fix the issue?

 

Steven

 

 

 

 

 

 

 

 

Ahra_G
Moderator

Hi @stevenhkwong, I tried checking your account using the username you provided however, no account was found. 

 

Although, I've managed to locate an account using your Community email address and found an NBN HFC connection. 

 

Could you please confirm your service address instead? 

stevenhkwong
Level 2

i have Pmed to Shane again with the username.

Hope that helps.

Steven