TPG Community

Get online support

D-Link DIR-X5460 can't connect to TPG

SOLVED Go to solution
Shane
Moderator

Hi @davidlee61,

 

I am sad to know that the D-Link modem/router did not connect to your TPG NBN. Do you still have the supplied TPG modem/router? If so, you may use it to access the internet while waiting for the repair/refund.

 

Regards,

 

 

Contacted the Tpg technical and they were unable to fix the connection issue and they referred me this post I hope they talk to D-Link and also remove this router from their recommended list,

I am now left in limbo and because of lockdown in Sydney cannot take it directly to the place of purchase for repairs or refund.
 
davidlee61
Level 3
Yes that’s what I did. however we have issues with this router too as its dropping out and the range is not stable
Deccas
Level 3

Unfortunately, it would appear that this router does not play well with TPG for some reason. I didn't go as far as getting my account reset, but I did change my password as it was quite short and had been in place for some time.  This didn't work either though.

I was never able to get the router to accept my TPG login and password when setting it up manually, so there may be something to that.  I don't know if there is a minimum character limit expectation (or character exclusion) set in the login process.

I was able to get the router to connect on a couple of occasions using the wizard but it was never stable and dropped out.

 

rkjohns
Level 2

Hi Guys.

I like many of you bought the D-Link DIR-X5460 based on TPG recomendations on their site. I rang support.  They couldnt do anything.  So I just reported them to the ACCC based on the below website.  My partner works in telecommincations and if they get enough complaints then TPG will start being monitored under ACMA watchdog which will start to cause them grief.  If TPG can state in their website "Our team has tested the following modems. Those with a tick are recommended for optimal use on our NBN Home Superfast or NBN Home Ultrafast plans." and I purchase a mdoem based on that recommendation, then they need to fix it with better support or pay me for my modem.  I have two months to go with TPG on a contract because we moved but after 10+ years with the company I will be moving on to someone who actaull cares about their customers.  Please report them if you have had issues.

 

https://www.accc.gov.au/contact-us/contact-the-accc/report-a-consumer-issue

 

davidlee61
Level 3
I hope Tpg does a new test and remove this router or even better let’s see if they can test asus ax86u 5700 as they suggested and put in the list. However this particular Asus router seems to be very popular and is in short supply 2 months ago it was around $320 and now even if you want to pay over $400 you cannot get it in Australia.

BTW I had a hard time trying to return D-Link router and getting a refund ( bought online) luckily I paid with PayPal so I requested a refund through them and seem to be getting it.

So at the moment still stack with to old TP link router.
Shane
Moderator

Hi All,

 

I was able to confirm that our Network Engineering Team, successfully tested the DIR-X5460 on our NBN services. 

 

it is possible that D-Link may have made firmware and/or hardware changes to the model we tested that may have resulted in this problem.

 

Our team will coordinate this with D-Link for further investigation, we'll provide an update when it becomes available.

 

Regards,

 

 

davidlee61
Level 3
Thanks Shane

While it’s probably late for me however other customers in future will benefit I managed to get asus ax86s 5700 from Amazon ( they are on special just now dropped the price to $300 ) which is the same as ax86u except it doesn’t have on 2.5gb gaming port which is ok with me.

Once i get it hopefully it works fine ( coming on 15)

I’ll let u guys know if it worked.
davidlee61
Level 3
Hi all

Good news I just got my Asus RT-AX86S 5700 today and on the first attempt it was connected with no issues whatsoever.
So there you go I recommend this router if anyone is interested
Shane
Moderator

Hi All,


Update on this thread:

Our Network Engineering Team tested this in our lab and confirmed there is no issue using the DIR-X5460 modem on both tagged or untagged connections on TPG network.

 

Please make sure that the modem/router is on latest firmware version (v1.10) and follow the troubleshooting below.

 

DIR-X5460 PPPoE Tagged Setup.

Follow the screenshots as an example for setting up the device:

 

  1. Click Next

    1.jpg

  2. Select TPG and click Next

    2.jpg

  3. For PPPoE services, select Yes and then Next

    3.jpg

  4. Put the username and password provided by ISP

    4.png

  5. Setup Wifi password and then Next

    5.jpg

  6. Set the modem login password and then Next

    6.jpg

  7. Set timezone then click Next
    7.jpg

  8. Select the relevant option to keep the device up to date and then Next

    8.jpg

  9. Click next

    9.jpg

  10. This may take upto 1min for the modem to configure

    10.jpg

  11. Confirm Connectivity

    11.png


    DIR-X5460 PPPoE Untagged Setup. 
  1. Click Next

    1.jpg

  2. Select TPG and click Next

    2.jpg
  3. For PPPoE services, select Yes and then Next

    3.jpg

  4. Put the username and password provided by ISP

    4.png

  5. Setup Wifi password and then Next

    5.jpg

  6. Set the modem login password and then Next

    6.jpg

  7. Set timezone then click Next

    7.jpg

  8. Select the relevant option to keep the device upto date and then Next

    8.jpg

  9. Click next

    9.jpg

  10. This may take upto 1min for the modem to configure

    10.jpg

  11. If there is no internet connectivity check step 


    11.jpg



  12. Go to setting on the top menu > then internet > Vlan and then disable Triple-Play


    12.jpg

  13. Confirm Connectivity
    13.jpg


Let us know how it will go.

david64
Level 12

@Shane . In the Untagged Setup, at the end, you disable Triple Play. In the Tagged Setup, you specify TPG as provider. Does this set the internet VLAN as 2 by default? If not, there is no instruction to change it.