TPG Community

Get online support

D-Link DIR-X5460 can't connect to TPG

SOLVED Go to solution
Shane
Moderator

Hi @david64,

 

We will clarify this with our Network Engineers and post the update on this thread.

 

Cheers!

 

 

@Shane . In the Untagged Setup, at the end, you disable Triple Play. In the Tagged Setup, you specify TPG as provider. Does this set the internet VLAN as 2 by default? If not, there is no instruction to change it.

SLR
Level 2
Level 2
Is there anyout come to this? Our router is 2 weeks old and we are a new tpg customer as of today. I cant return the router so i guess if its nit compatible im looking for a new ISP
davidlee61
Level 3
If you have your own router, then I suggest not to use the above unless TPG guarantees that it works.

Asus router I mentioned above is working well with no issues
david64
Level 13

Hi @SLR . In a previous post, the moderator mentions V1.10 of the firmware. 

What type of NBN connection do you have?

In the instructions for Untagged setup, they disable Triple Play. But the instructions for Tagged setup are not clear. They say to set TPG as provider, but there is no mention of how VLAN ID is set. It has to be done in the Triple Play section.

Have you read pages 55 and 56 of the user manual regarding Triple Play and VLAN setting? 

Niko1
Level 2
I experienced all the issues today as mentioned by Deccas, and numerous others. I have FTTP connection, tried disabling triple play the whole lot. Some issue with handshake as username/pw error when setting ISP to other. TPG is there any update from your contact with D-Link? Is it time to remove it from your recommended list. I wasted 5 hours today based on your recommendation.
david64
Level 13

Hi @Niko1 . This thread is quite old now. Might be best to start a new one but include the link to this one.

Also, reboot router and copy and paste the router's system log here; there might be a clue in it.

davidlee61
Level 3
Don’t wast your time get a different router
Deccas
Level 3

For some reason there is an unresolved issue with this router getting through the login/password stage of connecting to TPG.  Your best bet is to return this router and try another.  I opted for the ASUS RT-AX86U AX5700 and after a firmware update had no issues connecting, and haven't had any since purchase. This router is a bit more expensive than the D-Link, but worth it in my opinion.

I highly recommend that TPG remove this D-Link router from their approved list unless a fix is found.

Dariush55
Level 2
Hi Shane,
Thanks for the information.
I have the similar problem with DIR-X5460 and even D-link sent me another one but did not work as well.

What would be the next step?

Cheers,

Darius
rklugton
Level 2

So I purchased this router a week ago (same reason as everyone else - upgraded to ultrafast and looked at recommended routers on the TPG site).

I was having the same issues, called TPG but they just did the same troubleshooting as I.

I then logged a ticket with D-LInk.  Took a few goes but we have finally worked out the issue - seems something is not quite right with the TPG option either in the wizard or in the manual settings.

 

So this is what worked in the end:

- Settings>Intenet>VLAN   change ISP to OThers (not TPG). Save. (make sure you wait for the timer to confirmed that change has been saved)

Then on the same tab once the above is saved disable Triple play press save again.

It took a good 5 minutes to connect after this, but it finally did connect.

 

The guy at D-Link said he is going to lodge an internal ticket with their tech team to make an adjustment to the TPG wizard as there is obviously something not configured properly with that ISP setting.

Hopefully they will fix it in a firmware update & stop causing pain to TPG customers.

 

Hope that helps for others!  I almost thought I would have to return this nice looking router!