TPG Community

Get online support

How to get Xbox Live working on TP Link Routers

Level 3

I call BS on any fix that TPG has provided; none of these work and trying to get people to perform the same thing over and over again with the same results, well ... ... ... “Insanity is doing the same thing over and over again and expecting different results.”


The way I fixed it was by going out and buying a new router ... Which I shouldn't have to do because something that works on every other device normally takes 15 months (going by the original post) and no even acknowledgement of a problem.  Even to the point of asking how often I reboot my router; how frequently should I be rebooting it?  Every time I want to connect to Xbox Live?  I think not.  As soon as I turn on the xbox now with the new router, plugged in via ethernet.  Wow, it works straight away.  


This is clearly an issue with the devices you provided; clearly shown by the amount of people who have come to this thread.  


Level 2

How is this possible.

Just got TPG installed today. Can't get it to conect to Xbox with the VR1600v no matter what I try.... The add has a girl playing a console Smiley Happy

Level 3
The girl in the add is on a PS4 Smiley Happy
I have swapped modems around multiple times, the only time this issue occurs is with the TPG modem/router (even with all the ip /dmz / DNS stuff). Problem is Im now using a non standard router which compromises my support over the phone when I have issues.
Level 3

Just like others I have ditched the Archer for an Netgear Router/Modem and all is well, dont have VOIP but dont need it, goodluck everybody.

Level 2

I just got TPG NBN a couple of days ago and have the same Xbox One issues as the previous posters. When connected by wired connection to my new tplink router my Xbox live is no-go. However I also find my PC won't connect to the router, it says "cable unplugged", but if I move the same cable to my old adsl router it connects and gets an ip address (but no internet as the adsl has been turned off), so no problem with the cable or PC. Neither of these devices have fixed IPs at the moment.

From previous posts I imagine wifi would work but I don't want this as games that require stable low latency etc do not play as well over wifi.

It also looks like at present there is no solution other than ditching the router. Luckily I didn't get a fixed term contract with TPG NBN, I've been happy with TPG for 18 years(!) but I will regretfully have to try another provider if I can't resolve these problems. I don't want to but I'm not getting what I need, and from previous posts here I better not hold my breath for a fix.


Level 2

Did anyone ever get this fixed? I have the same problem with my archer on nbn hfc, i've set the ip as dmz/opened ports + set a static IP.


Level 3
Old post I know, and I don’t have this issue but it’s the only Xbox related one I can find. My game downloads from Xbox live at at most 2mbps (but mostly 5kbps. I’ve just had it going overnight and 105gig download is at 40% after 11 hours. Literally everything else runs smoothly at 40mbps+. It’s only game downloads. Any ideas?
Level 2

Hello tpg, I'm new to the community.

Has this issue been resolved? We recently transferred from long time tpg adsl no issues to hfc nbn now Xbox live won't work. Same issues and screen shots and tpg supplied router as described in this thread. Tried the suggested fixes in thread to no avail. TPG have you found a fix? Thanks.