TPG Community

Get online support

Mac OS 15 (Monterey) and Internet Connectivity

Level 2

Hi All


Recently, I upgraded my Mac to Monterey (15.0.1) and lost Internet connectivity.


Below is what I can do with my Mac :

  1. I can connect to my mobile hotspot with Internet access
  2. I can connect to my network extender (tp-link AC1200) with Internet access

Below is what I cannot do :

  1. I can connect to my Wifi Router (Archer VR1600v), but with no Internet access
  2. I can connect to my Powerline network extender (tp-link AV500), but with no Internet access

I have tried all the suggestions I could find, but could not resolve the issue.

Not sure if anyone else is having the same issue and/or managed to solve the problem, but appreciate if someone can help with this challenge.

Level 15

Hi @awte . Does your Mac have ethernet port or only wifi?

You have AV500 extender. What is the model of the other extender? AC1200 is not a model number.

Is the VR1600 used in normal config or in bridge mode?

Is the VR1600 Internet light on?

Suggest to get the VR1600 working properly. Have you rebooted it or tried factory reset?

Then reconnect each extender.

Depending on how each extender  connects to VR1600, part of it  might be broken.

Level 2

Hey @david64 

Thanks for your speedy reply !!

Please find below answers to the questions ...

  • My mac only has wifi
  • Model name for the AV500 extender is TL-WPA4227 KIT(AU) Ver: 1.0
  • Model name for the AV1200 extender is RE305(AU) Ver: 1.0
  • The VR1600 is running in normal mode with the Internet light on
  • I have rebooted the VR1600 once already.  My other devices (eg, Ipad, mobile phone, other Windows laptops) can connect the Internet with no issue.
  • My older Mac can connect to AV500 with no internet issues

A very curious situation.  Not sure if the AV500 or VR1600 needs patching.

Thanks again for your response !!

Level 15

@awte . When the Mac is connected to RE305, check its ip address. Use a Windows laptop connected to VR1600 or Powerline to ping the Mac. This should work.

Move the Mac to the other wifi, the one the Windows laptop is not on. Did the Mac get a new ip or keep previous one?

Ping whichever one the Mac is showing. Did it work?

If not, must be related to change in Monterey. Can you check the settings of the wifi adapter on the Mac? Compare with the old Mac.

Reboot the Mac and see if it gets internet.

There are hits for this problem on the internet but nothing from Apple. 

Level 2

Hey @david64 

Thanks again for replying !!

Below are the answers to the questions ...

  • Yes, I can confirm that my old Mac on the Powerline network can ping the Monterey mac on the RE305 network
  • I moved the Monterey mac to the VR1600 network and received a new IP address
  • Using the old Mac (on the Powerline network), I successfully pinged the Monterey mac on the VR1600 network
  • I have checked the settings on the old Mac with the Monterey Mac and they are the same
  • Here's what I have tried so far on the Monterey Mac (without success)
    1. Rebooting (several times already), plus shutting down overnight
    2. Removing the Wifi configuration and then re-applying the Wifi configuration
    3. Removing the Wifi configuration, rebooting and then re-applying the Wifi configuration

Some more information ...

  • I moved the Monterey mac back to the RE305 network and can successfully ping the TPG gateway (10.x.x.x) as well external sites (eg,
  • When I move the Monterey mac to the VR1600 or Powerline networks, pings to the TPG gateway time out as well as pings to external sites (ie,
  • In the last couple of days I bought a USB-C/Ethernet adaptor for the Monterey mac
    • When I plug-in the Monterey mac to the Powerline and VR1600 networks via cable/Ethernet, I can ping the TPG gateway and external sites

A really baffling issue ...

Thanks again.

Level 15

@awte . You mention a gateway on 10.x.x.x. Is that what the VR1600 calls its default gateway?

Do the extenders replicate the VR1600 SSIDs or do they create their own?

Can the new Mac ping the router from various locations using its wifi?

Can the old Mac and the other devices move freely between VR1600 and the extenders?

Have you checked the VR1600 system log? Its DHCPD component might indicate something. And Network, LAN Settings, Client List. 

Is the DHCP function disabled on the extenders?


Level 15

@awte . On VR1600, set the dhcp lease time to 20 minues. Connect new Mac to RE305. Everything should work.

Move new Mac to VR1600. Wait for 10 minutes (if it is like Windows) or wait 20 minutes for the lease to expire. Look at system log to see when this happens. Check if behaviour is different.

Then put lease time back to normal.


Level 2

Hey @david64 

Thanks for replying.

I have managed to resolve the issue.  It appears that something messed up one of the configuration files ( in /Library/Preferences/SystemConfiguration.

Below are the steps I took ...

  1. Took a copy of the backed up version
  2. Renamed the current version of to
  3. Renamed the backed up version to
  4. Rebooted the Monterey mac
  5. Re-added the VR1600 and Powerline networks

The above steps re-established Internet connectivity from both the VR1600 and Powerline networks.

Thanks again for your help.  It was deeply appreciated !!