TPG Community

Ask, answer and talk about our products

Very Slow Upload speed - NBN 50

SOLVED Go to solution
Level 2

Same problem. Extremely slow upload speed on NBN - 0.08 Mbps. It takes me an hour to make 300K email attachment, if I am lucky enough to successfully make it at all. Upload speed was quite ok for a few years, but dropped drastically last month. I am on 300 GB NBN contract (DSL).

Moderator

Hi @mchief,

 

Welcome to TPG Community!

 

We'd like to look into your account for better understanding of the situation.

 

We tried to locate your account using your community details to no avail.

 

Please send me a PM with your TPG username or customer ID number.

 

How to send a PM? Click here.

 

Regards,

BasilDV

Level 2

Hi @BasilDV ,

Please find my details in PM.

 

Cheers

Moderator

Hi @mchief,

 

Thanks for providing your account details and the speedtest result via PM.

 

Based on the screenshot you provided, it looks like the main issue is on the Upload speed. We performed tests and the upload speed that the modem detected was actually 25Mbps. So it looks like there's something off between the transfer of data from your modem to your devices.

 

We have refreshed your connection to see if that will improve your connection speed. Can you run a test and let us know how it goes?

 

Regards,

 

 

Highlighted
Level 2

Thanks @Will , it's all OK now!.

Level 2

Hi @Will , I'm having the same issues with my connection. Can you PM me with the solution you provided for @mchief  please?

 

Screenshot from 2019-10-23 12-22-13.png

Moderator

Hi @jmdejoanelli

 

Welcome to the Community!

 

From the screenshot you've posted, it looks like you're having trouble mostly with the upload speed. We need to pull up your account in order for us to know what service plan you're on and what's the best way to address the issue.

 

We've tried to check your account using your community details, but we can't seem to find an active account. Can you PM us your customer ID or username together with the service address?

 

For your reference: How do I private message (PM) in the community

 

Regards,

Moderator

Thanks for providing your account details, @jmdejoanelli

 

Our records show that you're on NBN50 which means that based on the screenshot you've provided, there's no issue with the download speed but your upload speed is indeed way too low.

 

We've made some adjustments to address it. Kindly test and let me know the results.

Level 2
Hi Will,

That fixed my issue! Thanks for your help!

Out of interest, what adjustment did you need to make?

Thanks again!
Moderator

I'm glad to hear that it's fixed, @jmdejoanelli,

 

Based on the speedtest result you provided, it appears that the bandwidth control on the router could have been set to below 1Mbps for upload. Since you're using a TPG supplied router, we just needed to refresh the connection for the router to get the correct upload bandwidth settings. The other option would have been for you to manually configure it from the router settings page.

 

If you have other concerns, feel free to leave us a message.