TPG Community

Get online support

Deco x20 connection to NBN HFC

Highlighted
Level 2
I have searched the support but the links don’t seem to work.

Network is up and running well now with NBN HFC box and TPG router/WiFi- both network cables and WiFi network.

I have a new TP Link Deco X20 Mesh set which I want to use to boost reception throughout the house.

The set-up for this has failed once I try to connect to the network. My questions are:

1. Should the X20 be connected to the NBN HFC box or the TPG router/WiFi unit.

2. The set up requires information on connection type. Default is dynamic IP. If this is not the case please advise which connection type I should use and the necessary details.

Many thanks for your help with this.

Dave
4 REPLIES 4
Highlighted
Level 9

Hi Dave.

1. If you want to use the VOIP phone service bundled with TPG, the TPG router has to connect to the NBN box. If you don't want to use the VOIP service, you have a choice of which to connect to the NBN box. If you connect the Deco to the NBN box, its wifi might be sufficient to not use the TPG router.

2. To use the Deco in place of TPG router, the connection type is PPPoE which requires your username with @TPG.com.au and your password (not the Community ones). In Advanced Features, Enable VLAN mode, Internet VLAN ID=2, priority=0. You can compare the settings between TPG router and Deco.

If you need the VOIP service, the Deco setup is different. There are several posts about connecting a second router and I'm not clear on what works.

Highlighted
Level 2
Thankyou so much - I tried the PPPoE last night before the reply without the VLAN info so I’ll give that a go today.
We don’t need the VOIP so hopefully you guidance will get us on-line. I’ll revert with the result once I’ve tried.
Highlighted
Level 2
Brilliant - the advice worked and I know have all 3 Deco x20 units providing strong WiFi signal with 100mb/s throughout the house.

The key part of the advice was TPG user name with “ @TPG.com.au “ at the end. I entered the VLan info in the set-up but left the IPTV settings blank.

Also one tip - if the set-up fails (red light) then use the reset button on the X20 device to get back to the installation beginning.

It took me about 6 attempts but once I had the right data from TPG community support it worked first time 😀
Highlighted
Level 1a