TPG Community

Get online support

TP-Link VR 900 AC 1900 V3 will not connect to HFC

SOLVED Go to solution
Highlighted
Moderator

Thank you @raymp.

 

I'm not able to identify as well on where to insert the settings.

 

Since it is being handled by the TP-Link Engineers, let's see if what will be their action to rectify the issue with your modem.

 

Regards,

BasilDV

Highlighted
Level 4

It is in wifi router mode,
Tp link engineer just sent me an email said it is to complicated for him and he has escalated it to a senior engineer, who is now on holidays untill may 4 , waiting game now  i suppose, in the mean time i will  try and get a refund,

 

Highlighted
Moderator

Hi @raymp,

 

Thanks for sharing this to us please keep us posted and let us know how it will go.

 

Cheers!

Highlighted
Level 4

This email from Tp link

I'm sorry to tell you that this model Archer VR900 V3 doesn't support VLAN ID setup yet while using Wireless Router mode.
It's suggested to change another model or hardware version with the retailer where you bought it.

 

Tough luck, thanks for buying, try for a refund, go try another.

 

Tp links packing is misleading, it says nbn ready, what it should say is nbn ready but not HFC

Highlighted
Moderator

Hi @raymp

 

Thanks for keeping us in the loop. I'm sorry though that it didn't work out the way you're expecting it to.

 

Regards,

Highlighted
Level 4
Could i have opinions on a d-link python ac 1600, it has a dedicated wan port and vlan tagging.
802.1q is needed for hfc, cannot see any mention if it in the specs
Highlighted
Moderator

Hi @raymp, this modem is an  ADSL/VDSL2 Modem Router and you can try to configure the settings to check if it will work for your NBN HFC service.

 

 

Level 4

I exchanged the tplink for a d-link python (thank you harvey norman for understanding)

it works painlessley and perfectly.

21 wifi clients attached.

I would recommend it for HFC.

 

View solution in original post

Highlighted
Level 1c

Hey all,

 

Just want to revive this thread as I've found a easy fix for this.

 

On the 31.1.2018 which is prior to this thread, TP-Link released an updated firmware which allows us to input the correct settings.

 

Release notes: 

1. Added VLAN Tagging function in Wireless Router Mode to support NBN/UFB.

 

Download their latest firmware here: https://www.tp-link.com/au/support/download/archer-vr900/#Firmware

 

- Choose your router hardware version & download.

- Go into your router settings, advanced, update firmware > unzip > direct to package.

 

Once the modem has rebooted, you can literally set up your internet under "Quick Setup" no need to tinker around further.

 

Hope this helps!

Highlighted
Moderator

Thank you, @gekoe. This is so helpful!