Weak Security

SOLVED Go to solution
mrspeel
Level 2

Trying to resolve the 'weak security' on my wifi which appeared after iOS 14 update.  My HG659 Huawei doesn't have the option to select either WAP2 (aes) or WAP3 - it's currently set to WPA-PSK+WPA-PSK.  I'm not very tech savvy so any help is appreciated. Thanks.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Shane
Moderator

Hi @mrspeel,

 

You do not need a new modem/router, you simply need to update the WIFI security settings on the modem/router's page.

 

To prevent the message from coming up the you need to change the WiFi settings of the modem/router to use newer more secure encryption.

 

You may simply change the WIFI settings like the image below this should eliminate the error message popping up to your Iphone's screen.

 

 

Note: some older devices that do not support WPA2 may no longer be able to connect after making the changes.

 

More details can be found on the Apple website:

 

https://support.apple.com/en-au/HT202068#security

 

Let us know should you require further assistance.

 

Regards,

 

 

Thanks for the reply!  Really appreciated.  Those settings are exactly what I have.  I reset them and 'saved' but still getting 'weak security'.  Do I need a new router? 🙁

View solution in original post

11 REPLIES 11
BryanR
Moderator

Hi mrspeel,

 

Whilst the HG659 is limited you can change the WiFi Security settings as per the two select field's in the modem under " WLAN Settings" pic below , dont forget to "SAVE" the changes, trust this helps - kind regards

HG659 WiFi Security SettingsHG659 WiFi Security Settings

 

mrspeel
Level 2

Thanks for the reply!  Really appreciated.  Those settings are exactly what I have.  I reset them and 'saved' but still getting 'weak security'.  Do I need a new router? 🙁

Shane
Moderator

Hi @mrspeel,

 

You do not need a new modem/router, you simply need to update the WIFI security settings on the modem/router's page.

 

To prevent the message from coming up the you need to change the WiFi settings of the modem/router to use newer more secure encryption.

 

You may simply change the WIFI settings like the image below this should eliminate the error message popping up to your Iphone's screen.

 

 

Note: some older devices that do not support WPA2 may no longer be able to connect after making the changes.

 

More details can be found on the Apple website:

 

https://support.apple.com/en-au/HT202068#security

 

Let us know should you require further assistance.

 

Regards,

 

 

Thanks for the reply!  Really appreciated.  Those settings are exactly what I have.  I reset them and 'saved' but still getting 'weak security'.  Do I need a new router? 🙁

View solution in original post

Emmashean
Level 2
Hi
I don’t have any of those options to update my encryption settings on my screen, only the name of the Wifi and the pin which is the number from the back of the modem unit.
Why don’t I have the option on my admin page under encryption settings?
I also have the weak security popping up on my phone. We’ve been having issues with our internet too.
Thanks
Emma
BasilDV
Moderator

Hi @Emmashean

 

Welcome to the Community!

 

We were able to locate your account using your community details and understand that you are still using the Huawei HG659 modem/router that we've provided.

The option that was given by @BryanR, should be available in the given tab.

 

You may send us a Screenshot of the settings that you are able to see in your WiFi/WLAN settings. This will help for us to provide you instructions.

 

Also, we can't detect any fault within the NBN network. Is there any particular issue that you are experiencing with your service?

 

BasilDV

Emmashean
Level 2
This is all I have available. It’s just been very weak in the house lately.
Thanks
Emma
BasilDV
Moderator

Hi @Emmashean

 

That's the quick setup page for the HG659 device.

 

When you click on Home, what are the options that it provided you?

Are you able to see the 'Home Network'?

 

For WiFi issues, it is possible that signal interference is causing it. You may refer to these articles to improve your home network.

BasilDV

 

BasilDV

Emmashean
Level 2
BasilDV
Moderator

Hi @Emmashean

 

Try to use a Computer instead of a mobile phone to access the Modem interface.

 

BasilDV