TPG Community

Ask, answer and talk about our products

SIM Activation issue after porting from Optus

Level 1b

- Received TPG SIM Friday 7 Sept and started activation process via website

- 5 days later activation is not complete?? Can receive calls and txt, but not make calls or txt, and have no mobile data access???

- Made numerous calls to TPG support to fix the issue, told I need to be patient and allow more time for activation???!!!

- Yet another call to support this afternoon, this time was advised there is an issue with network number porting. Escalated the issue to complaint status. Awaiting call back from TPG on day 6!!!

 

TPG, this is just not acceptable!!!!!

 

..and from I’m reading here in the community forum this seems to be a common problem for new TPG mobile clients??

 

5+ days and counting, frustration is building, compensation will be required!

 

 

4 REPLIES 4
Moderator

Hi @emilebos2,

 

Welcome to TPG Community!

 

We have located the account using your community details and we can see that the issue has been escalated.

 

We will make a follow up and will have an escalation officer contact you to discuss the status of the case.

 

We will also advise the assigned escalation officer to assess a billing adjustment as soon as the issue is resolved.

 

Moderator

Hi @emilebos2, we can see that our Mobile Team has been in touch and was able to confirm that the service is now working.

 

Should you need further assistance, feel free to drop us a message. Thank you.

Level 1b
So no follow up contact from customer service to discus billing adjustment compensation?

I won’t forget this poor client service experience TPG!
Moderator

Good day, emilebos2

 

The request for compensation has been approved and is already applied on your account. One of our Mobile specialists has tried to contact you to no avail. 

 

Should you have further queries, please don't hesitate to let us know. 

 

 

Thanks!