TPG Community

Get online support

How to get Xbox Live working on TP Link Routers


Thanks for the clarification @Clowndamage,


We'll make an investigation with our supplied TP-Link modem/router. On the other hand, I recommend to contact XboX support to see if they can provide you other resolution. We'll notify you once we got an update about this.



Level 3
I would have to say I'm having the same issue.
Post an outage on Friday when the DSL disconnected and then after a certain time reconnected did not get a good sync speed what I was used to. On the ASUS I was getting 10Mbps and post outage now 7Mbps.

Swapped to the TPG provided Archer VR1600v as NBN is finally due to be installed next week, now getting the original sync speeds.

But Xbox live not connecting is the issue with this router, I have set a static IP on the XBOX and it is only plugged directly into the router.

I see prior to putting it in the DMZ that the Teredo ports show open on the UPNP page. But does not connect to live (or allow me to log in to my account).

Set the DMZ to the Xbox and after rebooting the router it works. Turn off Xbox and back in, does not connect again.

Checked with Xbox support and they say it is a router issue.

Swapped back to the old ASUS router and connects to Xbox right away, but does not sync up as it originally did.

Now after many years being off contract with TPG and about to go back in contract for NBN, feel like I'm about to make a huge mistake.

Edit: After a reboot of router and Xbox, connected. Then play game not even 5 minutes into it I'm kicked out of live and can not log back in. This is ridiculous, if I go back to my old router it works but since the outage on Friday I get consistent low speeds and packet loss (from a router which was working fine previously and not even 4 months old)

Edit 2: Swapped over from wired to wireless, connected straight away - NAT says open when on the XBox network screen (whereas with wired even in a DMZ would get unavailable or moderate). Seems like an issue when plugged in via network cable.

Hi @Gryph,


Welcome to TPG Community!


Our network engineering teams are currently investigating this issue.


When you configure the static IP on your XBOX, what IP address are you using?


You should be selecting an IP in the to range to avoid conflict with the VR1600’s default DHCP range.


Kind regards,


Level 3
I tried both using within and outside the DHCP range.

When outside I had, and within .150 - I set them both to an IP which would not have any conflicts.

This happened on both instances though, you can see on the UPNP page that the Teredo ports are shown, but it does not appear that it is working correctly with the Xbox.

However when just connecting via wifi with no modifications it just worked and on the Xbox diags page it says open (as opposed to unavailable or moderate when wired)

Hope this helps.

Hi @Gryph,


It is unusual that it works via wireless and not via the LAN ports though. Have you tried different LAN ports or Ethernet cable?


Have you tried resetting the modem back to its default settings as well to start fresh?


Kind regards,


Level 5


I'm not an Xbox user but you may want to try editting the DCHP Settings of the modem and

Set the end IP address to 253 and set your Xbox IP address to 254 this will surely avoid any conflict with DHCP. Then change the DMZ Host IP to 254 as well.



Other thing you can try is use DHCP on your X-Box and Let the VR1600 give the IP addrss using the Address reservation and reserver a Specific IP for your Xbox.

Then Configure the DMZ settings for that IP address that's reserver for your X-Box.


Let me know if this help.



Level 3
The range is 100 - 199; 50 is well below the range and 150 is smack bang in the middle.

I always set a reservation based on MAC addresses before I set it to the DMZ; as otherwise is may not get the same IP. Unless it is statically assigned below DHCP.

As for trying another network cable or port, I can try this.

I'll try this later, as currently waiting for NBN tech to arrive (if they ever do) and then maybe might be able to test the router when connected up for NBN as opposed to ADSL.

Level 8

Hi @Gryph I've just read through this thread and I'm thinking it's more a basic issue such as the Ethernet connection running intermittently at half duplex, this might explain why it's ok on WiFi and hit and miss on Ethernet, can you confirm what speed your Xbox is connecting to the VR1600v.

Log in and click the VR1600v icon and your link speed on any lan port will be displayed on the bottom of the page as per pic below.



Level 3

Hi @orbistat,


I think you might be on the winner there; one thing I didn't look at.  But yes, correct - It is only getting 100Mbps when connecting via the ethernet cable.

Swapping with another cable which was previously showing as 1000Mbps and into another port still shows the same.  Although the process of unplugging and replugging in changed the Xbox network status from unavailable to open (effectively the same as rebooting either device)


Screen Shot 2019-01-12 at 08.15.33.png

I had it originally in LAN1 and shown as 100Mbps - Swapped to LAN4 and shown above as 100Mbps.  So not getting the full speed; so will swap back to wireless for now for a more reliable connection.


Side note - Still on ADSL as NBN did not happen yesterday, partly due to the original install location of the box outside.  Was placed under a fire hose which can cause a lot of water and the otherside of wall impedes use of door and no power nearby.  When originally I asked them to install it at a different location; which would mean an extra ~5m run of cable through the carpark basement which it is already doing and come up on a different wall and close to power and all equipment. So now back to them to get that box moved; Something that was originally slated back in 2017 now is pushed out even further. 

Level 3
Thanks for posting here, I tried most everything you did as well and no luck. I've just been running my Xbox on wifi since my first post.

Haven't had any trouble with other routers that wasn't solved by port forwarding. Hopefully we can get this resolved.