TPG Community

Get online support

TP-Link VR 900 AC 1900 V3 will not connect to HFC

SOLVED Go to solution
Level 4

I have a new router as listed above.

Cannot get an internet (nbn hfc) connection.

Attached are screen shots.

Any suggestions?

I have tried in in dsl mode, , no good

and in wireless router mode the cable connection dissapears on the router lights.

In wireless 


Accepted Solutions
Level 4

I exchanged the tplink for a d-link python (thank you harvey norman for understanding)

it works painlessley and perfectly.

21 wifi clients attached.

I would recommend it for HFC.


View solution in original post

Level 4

Hi @raymp try these settings


  1. Operation is in wireless router mode
  2. in advanced tab go to network > EWAN
  3. enter TPG username and password
  4. tag VLAN ID 2
  5. save


cheers! Smiley Very Happy


Level 4

Cannot find a ewan tab in network, all i can see is  default gateway settings

ewan_ppoe, see the attached pics

Level 4

The vlan id is only available when useing the setup wizard which is only available in dsl mode.

change it to wireless router mode, vlan id cannot be found.

i searched everywhere in the interface for it.


The only Wan reference i can find is in lan settings, if ipv6 is turned on a wan connection type becomes available,


where is the vlan id?

and is ipv6 relevant?












Level 4

I see. it does not have a stand-alone wan port.

have you connected the ethernet cable from the HFC to LAN4/WAN of the router?

can you possible tag vlan id in BASIC > INTERNET while on wireless router mode?

Level 4
It is connected to lan 4 wan
I have done the initial setup in the setup wizard it has vlan id 2 , tried internet before changing it wifi router mode , no internet in either mode
Level 4
I think this 802.1q setting that is in an asus router but missing from the tplink router may be yhe issue

Hi @raymp,


Once the modem is set to "Wireless router mode"


Go to "Network", then click on "Internet"


Please provide us a screenshot of what options we can see in it. It should allow you to add or configure the device with the correct settings.


We'll wait for the screenshot for us to proceed.




Level 4

Attached is a screen schot as asked  but,,,,,,,,,,,,,,,,,,,,

I have been on the phone to a tplink engineer, and i know this sounds crazy, but this is what happened.

The firmware version is correct, latest version.

2 settings are missing from the firmware, as you can see in the screen shot, there is no vlan id setting

and on the menu on the left there is no iptv setting.

Both according to the engineer should be in that shot and both are missing.

Now tplink at this stage have no idea,

how the settings are missing

why the settings are missing, and how many other routers have the same fault,

and are still working on the problam.

If you can see something in the screen shot tplink cannot see, please let me know

Level 8

Hi @raymp when you click save on the ewan_pppoe option does it not take? Wireless router mode as @legcat and @BasilDV  have suggested is what you need to be in.